flutter_cupertino_data_picker 0.8.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 69

pub package

flutter_cupertino_data_picker #

flutter cupertino data_picker.

Getting Started #

Screenshot

Usage #

void _showDataPicker() {
       final bool showTitleActions = true;
       DataPicker.showDatePicker(
         context,
         showTitleActions: showTitleActions,
         locale: 'zh',
         datas: ['男', '女'],
         title: '选择性别',
         onChanged: (data) {
           print('onChanged date: $data');
         },
         onConfirm: (data) {
           print('onConfirm date: $data');
         },
       );
     }

Use this package as a library #

  1. Depend on it Add this to your package's pubspec.yaml file:
dependencies:
  flutter_cupertino_data_picker: ^0.8.3
  1. Install it You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

  1. Import it Now in your Dart code, you can use:
import 'package:flutter_cupertino_data_picker/flutter_cupertino_data_picker.dart';

Fork by https://github.com/wuzhendev/flutter-cupertino-date-picker

[0.8.3] - 2018.12.5

  • update flutter 1.0.0.

[0.8.1] - 2018.9.21

  • update doc.

[0.8.0] - 2018.9.20

  • fix line color.

[0.0.1] - initial.

  • initial.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_cupertino_data_picker: ^0.8.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_cupertino_data_picker/flutter_cupertino_data_picker.dart';
  
Version Uploaded Documentation Archive
0.8.3 Dec 5, 2018 Go to the documentation of flutter_cupertino_data_picker 0.8.3 Download flutter_cupertino_data_picker 0.8.3 archive
0.8.2 Oct 12, 2018 Go to the documentation of flutter_cupertino_data_picker 0.8.2 Download flutter_cupertino_data_picker 0.8.2 archive
0.8.1 Sep 21, 2018 Go to the documentation of flutter_cupertino_data_picker 0.8.1 Download flutter_cupertino_data_picker 0.8.1 archive
0.8.0 Sep 20, 2018 Go to the documentation of flutter_cupertino_data_picker 0.8.0 Download flutter_cupertino_data_picker 0.8.0 archive
0.7.0 Sep 14, 2018 Go to the documentation of flutter_cupertino_data_picker 0.7.0 Download flutter_cupertino_data_picker 0.7.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
56
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
55
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Apr 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_cupertino_data_picker.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test