flutter_eventemitter 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new52

eventemitter

Dependency free publish/subscribe(pub/sub) for dart&flutter.

How to use

Open the pubspec.yaml file, and add eventemitter: unde dependencies:

  dependencies:
    flutter:
      sdk: flutter
    # ...
    # ...
    eventemitter: ^0.1.3

install it from terminal: Run flutter packages get

Example

String token = EventEmitter.subscribe('topic', (data) {
  // receive 2
  print(data);
});

// publish is async function
EventEmitter.publish('topic', 1)
EventEmitter.publishSync('topic', 2)
EventEmitter.unsubscribe(token);

[0.1.0] - 2018-11-21

  • initial

[0.1.1] - 2018-11-22

  • factory readme doc

example/main.dart

import 'package:flutter_eventemitter/flutter_eventemitter.dart';

void main() {
  const MESSAGE = '___message__';

  EventEmitter.subscribe(MESSAGE, (data) {
    // will receive 1 and 2
    // todo: something
  });

  EventEmitter.subscribeOnce(MESSAGE, (data) {
    // will receive 1
    // todo: something
  });

  EventEmitter.publishSync(MESSAGE, 1);
  EventEmitter.publishSync(MESSAGE, 2);

  // remove subscriber
  EventEmitter.clear(MESSAGE);

  subscriber(data) {}

  String token = EventEmitter.subscribe(MESSAGE, subscriber);
  EventEmitter.unsubscribe(token);
  EventEmitter.unsubscribe(subscriber);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_eventemitter: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_eventemitter/flutter_eventemitter.dart';
  
Version Uploaded Documentation Archive
0.1.1 Nov 22, 2018 Go to the documentation of flutter_eventemitter 0.1.1 Download flutter_eventemitter 0.1.1 archive
0.1.0 Nov 21, 2018 Go to the documentation of flutter_eventemitter 0.1.0 Download flutter_eventemitter 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
9
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
52
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-10 points)

13 out of 13 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test