flutter_fbads 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new48

flutter_fbads(Only Android) #

Flutter Facebook Audience Network Interstitial Ad Plug in. You can use Facebook Audience Network Interstitial with this plugin in Flutter Only on Android. Banners, and native are not supported.

pubspec.yml (install dependency) #

dependencies:
    flutter_fbads:
        git:
           url: https://gitlab.com/kyungjoongo/flutter_fbads.git

import package #

import 'package:flutter_fbads/flutter_fbads.dart';

usage #

//your facebook audience network Interstitial ad id.
String adId = '394084851148824_394085212345678';

//show Interstitial ad .
FlutterFbads.showInitAd(adId);

0.0.1 #

  • TODO: Describe initial release.

example/README.md

flutter_fbads_example #

Demonstrates how to use the flutter_fbads plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_fbads: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_fbads/flutter_fbads.dart';
  
Version Uploaded Documentation Archive
0.0.3 Mar 2, 2019 Go to the documentation of flutter_fbads 0.0.3 Download flutter_fbads 0.0.3 archive
0.0.2 Mar 2, 2019 Go to the documentation of flutter_fbads 0.0.2 Download flutter_fbads 0.0.2 archive
0.0.1 Mar 2, 2019 Go to the documentation of flutter_fbads 0.0.1 Download flutter_fbads 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
9
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Mar 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

5 out of 5 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flutter_fbads.dart.

Run flutter format to format lib/flutter_fbads.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test