flutter_flipperkit 0.0.6

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new77

flutter_flipperkit #

pub package Donate

English | 简体中文

Introduction #

Flipper (Extensible mobile app debugger) for flutter.

Features #

  • Network inspector network

  • Shared preferences (and UserDefaults) inspector shared-preferences

  • Redux inspector

Quick Start #

Prerequisites #

Before starting make sure you have:

Installation #

Add this to your package's pubspec.yaml file:

dependencies:
  flutter_flipperkit: ^0.0.6

Change your project ios/Podfile file according to the example:

+source 'https://github.com/facebook/flipper.git'
+source 'https://github.com/CocoaPods/Specs'
# Uncomment this line to define a global platform for your project
-# platform :ios, '9.0'
+platform :ios, '9.0'

Change your project files according to the example:

android/app/build.gradle:

android {
-    compileSdkVersion 27
+    compileSdkVersion 28

    defaultConfig {
-        targetSdkVersion 27
+        targetSdkVersion 28
    }
}

android/app/gradle.properties:

+android.useAndroidX=true
+android.enableJetifier=true

You can install packages from the command line:

$ flutter packages get

Usage #

import 'package:flutter_flipperkit/flutter_flipperkit.dart';

void main() {
  FlipperClient flipperClient = FlipperClient.getDefault();

  flipperClient.addPlugin(new FlipperNetworkPlugin());
  flipperClient.addPlugin(new FlipperReduxInspectorPlugin());
  flipperClient.addPlugin(new FlipperSharedPreferencesPlugin());
  flipperClient.start();

  runApp(MyApp());
}

...

Please refer to flutter_starter project, to integrate flutter_flipperkit into your project.

Run the app #

$ flutter run

Known Issues (to note) #

  • [iOS] If you use cocoapods 1.6.0 or later, does not support the use_frameworks!

Discussion #

If you have any suggestions or questions about this project, you can discuss it by Telegram or my wechat.

License #

MIT License

Copyright (c) 2019 JianyingLi <lijy91@foxmail.com>

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

0.0.6 #

  • Add payloadprevStatenextState to newAction event

0.0.5 #

  • Add ReduxInspector Plugin
  • Upgrade flipper to 0.18.0

0.0.4 #

  • Fix dart low version dependency failure
  • Upgrade flipper to 0.17.0

0.0.3 #

  • Add dio 2.0 example
  • [Android] Fix json array data convert will crash
  • [iOS] Add use_frameworks! example (only cocoapods 1.5.3)

0.0.2 #

  • Add SharedPreferencesPlugin

0.0.1 #

  • Initial release

example/README.md

flutter_flipperkit_example #

Demonstrates how to use the flutter_flipperkit plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_flipperkit: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_flipperkit/flutter_flipperkit.dart';
  
Version Uploaded Documentation Archive
0.0.6 Mar 17, 2019 Go to the documentation of flutter_flipperkit 0.0.6 Download flutter_flipperkit 0.0.6 archive
0.0.5 Mar 16, 2019 Go to the documentation of flutter_flipperkit 0.0.5 Download flutter_flipperkit 0.0.5 archive
0.0.4 Mar 7, 2019 Go to the documentation of flutter_flipperkit 0.0.4 Download flutter_flipperkit 0.0.4 archive
0.0.3 Feb 26, 2019 Go to the documentation of flutter_flipperkit 0.0.3 Download flutter_flipperkit 0.0.3 archive
0.0.2 Feb 24, 2019 Go to the documentation of flutter_flipperkit 0.0.2 Download flutter_flipperkit 0.0.2 archive
0.0.1 Feb 23, 2019 Go to the documentation of flutter_flipperkit 0.0.1 Download flutter_flipperkit 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
81
Overall:
Weighted score of the above. [more]
77
Learn more about scoring.

We analyzed this package on Mar 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

75 out of 75 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/flipper_client.dart. (-0.50 points)

Analysis of lib/flipper_client.dart reported 1 hint:

line 1 col 8: Unused import: 'dart:async'.

Format lib/flipper_plugin.dart.

Run flutter format to format lib/flipper_plugin.dart.

Format lib/flutter_flipperkit.dart.

Run flutter format to format lib/flutter_flipperkit.dart.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/plugins/network/flipper_network_plugin.dart (Run flutter format to format lib/plugins/network/flipper_network_plugin.dart.)
  • lib/plugins/plugins.dart (Run flutter format to format lib/plugins/plugins.dart.)
  • lib/plugins/redux/flipper_reduxinspector_plugin.dart (Run flutter format to format lib/plugins/redux/flipper_reduxinspector_plugin.dart.)
  • lib/plugins/sharedpreferences/flipper_shared_preferences_plugin.dart (Run flutter format to format lib/plugins/sharedpreferences/flipper_shared_preferences_plugin.dart.)

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Update README.md. (-2 points)

1 image link is insecure (e.g. http://blankapp.org/assets/images/wechat_qrcode.png), use https URLs instead.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test