flutter_grid_delegate_ext 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 64

Simple SliverGridDelegate extension #

Simple SliverGridDelegate extension, Height of big cell and small cell can be adjusted, BigCellHeight >= SmallCellHeight.

pub package

Installation #

Add dependency in pubspec.yaml:

dependencies:
  flutter_grid_delegate_ext: "^0.0.2"

Import in your project:

import 'package:flutter_grid_delegate_ext/flutter_grid_delegate_ext.dart';

Basic usage #

Unequal cells height with first cell small #

GridView.builder(
    gridDelegate: XSliverGridDelegate(
        crossAxisCount: 3,
        smallCellExtent: 100,
        bigCellExtent: 200,
        mainAxisSpacing: 5,
        crossAxisSpacing: 5,
        isFirstCellBig: false
    )
)

Unequal cells height with first cell big #

GridView.builder(
    gridDelegate: XSliverGridDelegate(
        crossAxisCount: 3,
        smallCellExtent: 100,
        bigCellExtent: 200,
        mainAxisSpacing: 5,
        crossAxisSpacing: 5,
        isFirstCellBig: true
    )
)

Equal cells height #

GridView.builder(
    gridDelegate: XSliverGridDelegate(
        crossAxisCount: 3,
        smallCellExtent: 200,
        bigCellExtent: 200,
        mainAxisSpacing: 5,
        crossAxisSpacing: 5,
    )
)

Examples #

example project contains demo

Bugs/Requests #

Reporting issues and requests for new features are always welcome.

0.0.2 #

  • Changes to docs and package name

0.0.1 #

  • Initial version

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_grid_delegate_ext: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_grid_delegate_ext/flutter_grid_delegate_ext.dart';
  
Version Uploaded Documentation Archive
0.0.2 Feb 11, 2019 Go to the documentation of flutter_grid_delegate_ext 0.0.2 Download flutter_grid_delegate_ext 0.0.2 archive
0.0.1 Feb 11, 2019 Go to the documentation of flutter_grid_delegate_ext 0.0.1 Download flutter_grid_delegate_ext 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Apr 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/rendering/grid_delegate.dart. (-0.50 points)

Analysis of lib/rendering/grid_delegate.dart reported 1 hint:

line 91 col 8: The method '_debugAssertIsValid' isn't used.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test