flutter_html_view 0.5.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 87

flutter_html_view

Flutter Plugin to render html as a Widget,

Flutter has no default support to render html so this package helps you to render your html to native widgets

  • Video tag support added
  • Links are clickable now

Supported Tags

  • p
  • em
  • b
  • img
  • video
  • h1, h2, h3, h4, h5, h6

Note

  • This plugin converts some of the html tags to flutter widgets
  • This plugin does't support rendering full html code (there is no built in support for web rendering in flutter)

How to Use


dependencies:
  flutter_html_view: "^0.5.1"
  

import 'package:flutter_html_textview/flutter_html_textview.dart';

String html = '<body>Hello world! <a href="www.html5rocks.com">HTML5 rocks!';

new HtmlTextView(data: html);

Thanks to

@Katran

[0.5.2]

  • support for data:image parsing for inline base64 images added

[0.5.1]

  • Bug Fixes

[0.5.0]

  • Video tag is not supported

[0.4.0]

  • Links are clickable now

[0.3.0]

  • Initial release

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_html_view/flutter_html_view.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {

  @override
  initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {

    String html = '<h1>This is &nbsp;heading 1</h1> <h2>This is heading 2</h2><h3>This is heading 3</h3><h4>This is heading 4</h4><h5>This is heading 5</h5><h6>This is heading 6</h6><p><img alt="Test Image" src="https://i.ytimg.com/vi/RHLknisJ-Sg/maxresdefault.jpg" /></p><p><video src="https://flutter.github.io/assets-for-api-docs/videos/bee.mp4"></video></p><a href="https://google.com">Go Google</a> <a href="mailto:ponnamkarthik3@gmail.com">Mail to me</a> ';

    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        ),
        body: new SingleChildScrollView(
          child: new Center(
            child: new HtmlView(data: html,),
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_html_view: "^0.5.2"

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:flutter_html_view/flutter_html_view.dart';
  
Version Uploaded Documentation Archive
0.5.2 Jun 9, 2018 Go to the documentation of flutter_html_view 0.5.2 Download flutter_html_view 0.5.2 archive
0.5.1 May 24, 2018 Go to the documentation of flutter_html_view 0.5.1 Download flutter_html_view 0.5.1 archive
0.5.0 May 24, 2018 Go to the documentation of flutter_html_view 0.5.0 Download flutter_html_view 0.5.0 archive
0.4.0 Apr 22, 2018 Go to the documentation of flutter_html_view 0.4.0 Download flutter_html_view 0.4.0 archive
0.3.1 Apr 17, 2018 Go to the documentation of flutter_html_view 0.3.1 Download flutter_html_view 0.3.1 archive
0.3.0 Apr 17, 2018 Go to the documentation of flutter_html_view 0.3.0 Download flutter_html_view 0.3.0 archive
0.2.7 Apr 17, 2018 Go to the documentation of flutter_html_view 0.2.7 Download flutter_html_view 0.2.7 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3
  • Flutter: 0.5.4

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
76 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
87
Learn more about scoring.

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 warning 5 hints.

    Strong-mode analysis of lib/html_parser.dart gave the following warning:

    line: 15 col: 3
    This function declares a return type of 'Widget', but doesn't end with a return statement.

    Run flutter format to format lib/flutter_html_text.dart.

    Similar analysis of the following files failed:

    • lib/flutter_html_view.dart (hint)
  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
cached_network_image ^0.4.0 0.4.1+1
flutter 0.0.0
flutter_custom_tabs ^0.1.0 0.1.0 0.2.0
html ^0.13.3 0.13.3+1
video_player ^0.5.2 0.5.4 0.6.1
Transitive dependencies
args 1.4.3
async 2.0.7
charcode 1.1.1
collection 1.14.6 1.14.10
convert 2.0.1
crypto 2.0.5
csslib 0.14.4
flutter_cache_manager 0.1.1
http 0.11.3+16
http_parser 3.1.2
logging 0.11.3+1
meta 1.1.5
path 1.6.0 1.6.1
path_provider 0.4.1
shared_preferences 0.4.2
sky_engine 0.0.99
source_span 1.4.0
string_scanner 1.0.2
synchronized 1.5.0+1
typed_data 1.1.5
url_launcher 3.0.2
utf 0.9.0+4
uuid 0.5.3 1.0.0
vector_math 2.0.6 2.0.7