flutter_install_app_plugin 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new74

flutter_install_app_plugin

A Flutter plug-in helps to install iOS and Android apps.

Usage

It is not uncommon that you may want to ask a user to install another app within your app. What you need to do here is to prepare a set of iOS app ID on App Store, and Android package name.

For example, if you want to lead your customers to install KKBOX, you need to create an app set like:

    var app = AppSet();
    app.iosAppId = 300915900;
    app.androidPackageName = 'com.skysoft.kkbox.android';

Then call the plug-in.

    FlutterInstallAppPlugin.installApp(app);

On iOS, the plug-in calls SKStoreProductViewController, while it creates an activity to open a "market://" URL on Android.

That's all. Enjoy!

0.1.1

  • Clean undesired files.

0.1.0

  • The first release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_install_app_plugin/flutter_install_app_plugin.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        ),
        body: new Center(
            child: new RaisedButton(
          color: Theme.of(context).primaryColor,
          onPressed: () {
            var app = AppSet();
            app.iosAppId = 300915900;
            app.androidPackageName = 'com.skysoft.kkbox.android';
            FlutterInstallAppPlugin.installApp(app);
          },
          child: Text(
            'Install App',
            style: TextStyle(color: Colors.white),
          ),
        )),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_install_app_plugin: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_install_app_plugin/flutter_install_app_plugin.dart';
  
Version Uploaded Documentation Archive
0.1.1 Oct 5, 2018 Go to the documentation of flutter_install_app_plugin 0.1.1 Download flutter_install_app_plugin 0.1.1 archive
0.1.0 Sep 27, 2018 Go to the documentation of flutter_install_app_plugin 0.1.0 Download flutter_install_app_plugin 0.1.0 archive
0.0.1 Sep 27, 2018 Go to the documentation of flutter_install_app_plugin 0.0.1 Download flutter_install_app_plugin 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8