flutter_is_emulator 1.0.0

  • README.md
  • Example
  • Installing
  • Versions
  • new49

Flutter Is Emulator plugin

Plugin to detect whether the current device is an emulator or a simulator.

Getting Started

First, you have to import the package in your dart files with:

import 'package:flutter_is_emulator/flutter_is_emulator.dart';

Then you just have to request if the device is an emulator (Android) or a simulator (iOS) with:

bool isAnEmulator = await FlutterIsEmulator.isDeviceAnEmulatorOrASimulator;

[1.0.0] - 10th April 2018

  • Initial Release.


import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:flutter_is_emulator/flutter_is_emulator.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => new _MyAppState();

class _MyAppState extends State<MyApp> {
  String _text = 'Unknown';

  initState() {

  initPlatformState() async {
    String text;
    try {
      bool res = await FlutterIsEmulator.isDeviceAnEmulatorOrASimulator;
      text = res.toString();
    } on PlatformException {
      text = 'Error.';

    if (!mounted) return;

    setState(() {
      _text = text;

  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        body: new Center(
          child: new Text('Emulator/simulator: $_text\n'),

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_is_emulator: "^1.0.0"

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_is_emulator/flutter_is_emulator.dart';
Version Uploaded Documentation Archive
1.0.0 Apr 10, 2018 Go to the documentation of flutter_is_emulator 1.0.0 Download flutter_is_emulator 1.0.0 archive


We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6
  • Flutter: 0.3.2


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
98 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 hint.

    Strong-mode analysis of lib/generated/i18n.dart gave the following hint:

    line: 28 col: 7
    Name types using UpperCamelCase.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.6 1.14.9
meta 1.1.2
sky_engine 0.0.99
typed_data 1.1.5
vector_math 2.0.6