Flutter polyfills for dart:js APIs
This polyfills APIs in dart:js, which is not included in the Flutter SDK. This allows flutter and non-flutter packages to co-exist in the same IntelliJ package. An example of this is described here: https://github.com/apptreesoftware/letsvote#intellj-multi-module-setup
Add this to your package's pubspec.yaml file:
dependencies: flutter_js_polyfill: "^1.0.1"
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.1||Jun 14, 2018|
|1.0.0||Jun 14, 2018|
We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: web, other
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
Fix analysis and formatting issues.
Analysis or formatting checks reported 3 hints.
Strong-mode analysis of
lib/flutter_js_polyfill.dartgave the following hint:
line: 5 col: 9
The generic type comment is being deprecated in favor of the real syntax.
|Dart SDK||>=1.20.1 <2.0.0|