flutter_js_polyfill 2.0.0

  • README.md
  • Installing
  • Versions
  • 28


Flutter polyfills for dart:js APIs

This polyfills APIs in dart:js, which is not included in the Flutter SDK. This allows flutter and non-flutter packages to co-exist in the same IntelliJ package. An example of this is described here: https://github.com/apptreesoftware/letsvote#intellj-multi-module-setup


  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_js_polyfill: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_js_polyfill/flutter_js_polyfill.dart';
Version Uploaded Documentation Archive
2.0.0 Jun 26, 2018 Go to the documentation of flutter_js_polyfill 2.0.0 Download flutter_js_polyfill 2.0.0 archive
1.0.2 Jun 25, 2018 Go to the documentation of flutter_js_polyfill 1.0.2 Download flutter_js_polyfill 1.0.2 archive
1.0.1 Jun 14, 2018 Go to the documentation of flutter_js_polyfill 1.0.1 Download flutter_js_polyfill 1.0.1 archive
1.0.0 Jun 14, 2018 Go to the documentation of flutter_js_polyfill 1.0.0 Download flutter_js_polyfill 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0