flutter_logger 0.0.4+1

  • README.md
  • Installing
  • Versions
  • 38

flutter_logger #

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:flutter_logger/flutter_logger.dart';

main() {
  var awesome = new Awesome();

Features and bugs #

Please file feature requests and bugs at the issue tracker.

[0.0.4] - September 21, 2018

  • fix addTag
  • [BRAKING CHANGE] removed option for opting out of tag formatting

[0.0.3] - August 21, 2018

  • update SDK version

[0.0.2] - July 16, 2018

  • minor changes

[0.0.1] - November 2, 2017

  • initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_logger: ^0.0.4+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_logger/flutter_logger.dart';
Version Uploaded Documentation Archive
0.0.4+1 Sep 21, 2018 Go to the documentation of flutter_logger 0.0.4+1 Download flutter_logger 0.0.4+1 archive
0.0.4 Sep 21, 2018 Go to the documentation of flutter_logger 0.0.4 Download flutter_logger 0.0.4 archive
0.0.3 Aug 21, 2018 Go to the documentation of flutter_logger 0.0.3 Download flutter_logger 0.0.3 archive
0.0.2 Jul 16, 2018 Go to the documentation of flutter_logger 0.0.2 Download flutter_logger 0.0.2 archive
0.0.1 Nov 1, 2017 Go to the documentation of flutter_logger 0.0.1 Download flutter_logger 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK <=3.0.0