flutter_lxp_date 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new44

flutter_lxp_date #

A Get Time Flutter plugin. 因为flutter里面不能获取本周本季度本月本年的时间,所以想着自己开发个插件给大家使用,目前Android可以使用,后期开发Ios(等我买了苹果电脑在说!!!),本人QQ695343920,可以一起向着技术方向前进。

pub # ![][当前图片路径(https://ctfive.oss-cn-hangzhou.aliyuncs.com/Student/2019/02/24/0521db125c044fb7ba96566349bbada10163.png)]

Usage # To use this plugin, add flutterlxpdate as a dependency in your pubspec.yaml file.

Example #

import 'package:flutter/material.dart'; import 'dart:async';

import 'package:flutter/services.dart'; import 'package:flutter_lxp_date/flutter_lxp_date.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget { @override _MyAppState createState() => _MyAppState(); }

class _MyAppState extends State<MyApp> { String _platformTime = 'Unknown';

@override void initState() { super.initState(); initPlatformState(); }

// Platform messages are asynchronous, so we initialize in an async method. Future<void> initPlatformState() async { String platformTime; // Platform messages may fail, so we use a try/catch PlatformException. try { platformTime = await FlutterLxpDate.platformTime; } on PlatformException { platformTime = 'Failed to get platform time.'; }

// If the widget was removed from the tree while the asynchronous platform
// message was in flight, we want to discard the reply rather than calling
// setState to update our non-existent appearance.
if (!mounted) return;

setState(() {
  _platformTime = platformTime;
});

}

@override Widget build(BuildContext context) { return MaterialApp( home: Scaffold( appBar: AppBar( title: const Text('Plugin example app'), ), body: Center( child: Text('Running on: $_platformTime\n'), ), ), ); } }

0.0.1 #

  • TODO: Describe initial release.

Get this week, this month, this year

example/README.md

flutter_lxp_date_example #

Demonstrates how to use the flutter_lxp_date plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_lxp_date: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_lxp_date/flutter_lxp_date.dart';
  
Version Uploaded Documentation Archive
0.0.1 Feb 24, 2019 Go to the documentation of flutter_lxp_date 0.0.1 Download flutter_lxp_date 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Mar 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/flutter_lxp_date.dart. (-0.50 points)

Analysis of lib/flutter_lxp_date.dart reported 1 hint:

line 10 col 18: Name non-constant identifiers using lowerCamelCase.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8