flutter_map 0.0.11+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 47

flutter_map

Experimental

See the github repository for documentation

[0.0.11] - 8/2/2018

  • upgrade to latlong from 0.4.0 to 0.5.3

[0.0.11] - 7/31/2018

  • fix LICENSE spelling error
  • double-tap to zoom (#62)
  • Fix polyline overlap issue (#67)
  • Offline map example (#53)

Thanks to contributors @alfanhui, @avioli, @solid-software, and @vinicentus for this release!

[0.0.10] - 6/7/2018

  • update .gitignore (#40)
  • Applied constraints to zoom on gesture update if min or max options set (#46)
  • Pan Boundary with 2 new MapOptions variables: swPanBoundary and nePanBoundary (#47)
  • OfflineMode bool variable added to TileLayerOptions for AssetImage Widget use (#48)
  • remove quiver dep (#32)

Thanks to contributors @avioli, @bcko, and @alfanhui for this release!

[0.0.9] - 5/31/2018

  • add LatlngBounds.contains, avoid rendering out-of-view markers in MarkerLayer

[0.0.8] - 5/31/2018

  • bug: rendering far-away tiles was causing a GPU crash on the simulator. add tile pruning to TileLayer

[0.0.7] - 5/29/2018

  • bug: TileLayer not listening to onMoved events from MapController

[0.0.6] - 5/11/2018

  • fitBounds, onPositionChanged (#39)

[0.0.5] - 3/11/2018

  • make tile background customizable (#36)
  • use transparent_image as placeholder image (#37)

[0.0.4] - 4/18/2018

  • Add marker anchor support (#27, #30)

[0.0.3] - 4/18/2018

  • fixed Dart 2.0 type errors (#23)
  • add MapController API (#24 + #25)

[0.0.2] - 2/21/2018

  • subdomain support
  • move gesture detection into map widget
  • improved tile layer support
  • improved examples
  • Polyline layers
  • fix marker redraw on map rotation

[0.0.1] - 2/5/2018

  • inital release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_map: ^0.0.11+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_map/flutter_map.dart';
  
Version Uploaded Documentation Archive
0.0.11+1 Aug 2, 2018 Go to the documentation of flutter_map 0.0.11+1 Download flutter_map 0.0.11+1 archive
0.0.11 Jul 31, 2018 Go to the documentation of flutter_map 0.0.11 Download flutter_map 0.0.11 archive
0.0.10 Jun 7, 2018 Go to the documentation of flutter_map 0.0.10 Download flutter_map 0.0.10 archive
0.0.9 May 31, 2018 Go to the documentation of flutter_map 0.0.9 Download flutter_map 0.0.9 archive
0.0.8+1 May 31, 2018 Go to the documentation of flutter_map 0.0.8+1 Download flutter_map 0.0.8+1 archive
0.0.8 May 31, 2018 Go to the documentation of flutter_map 0.0.8 Download flutter_map 0.0.8 archive
0.0.7 May 30, 2018 Go to the documentation of flutter_map 0.0.7 Download flutter_map 0.0.7 archive
0.0.6 May 11, 2018 Go to the documentation of flutter_map 0.0.6 Download flutter_map 0.0.6 archive
0.0.5 May 11, 2018 Go to the documentation of flutter_map 0.0.5 Download flutter_map 0.0.5 archive
0.0.4 Apr 25, 2018 Go to the documentation of flutter_map 0.0.4 Download flutter_map 0.0.4 archive

All 18 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
94
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0