ESRI basemaps for flutter_map. This does NOT provide esri FeatureLayers or other layers.
new FlutterMap( options: new MapOptions( center: new LatLng(34.0231688, -118.2874995), zoom: 17.0, ), layers: [ new EsriBasemapOptions( esriBasemapType: EsriBasemapType.streets), ], );
EsriBasemapOptions implements TileLayerOptions.
Add this to your package's pubspec.yaml file:
dependencies: flutter_map_esri: ^0.0.4
You can install packages from the command line:
$ flutter packages get
Alternatively, your editor might support
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.4||Aug 21, 2018|
|0.0.3||May 18, 2018|
|0.0.2||May 17, 2018|
|0.0.1||May 17, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
Document public APIs. (-1 points)
23 out of 23 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.
Homepage URL does not exists. (-20 points)
We were unable to access
https://github.com/apptreesoftware/flutter_map_esri at the time of the analysis.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
Package is pre-v0.1 release. (-10 points)
While there is nothing inherently wrong with versions of
0.0.*, it usually means that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.0.0 <3.0.0|