A markdown renderer for Flutter. It supports the original format, but no inline html.
Using the Markdown widget is simple, just pass in the source markdown as a string:
new Markdown(data: markdownSource);
If you do not want the padding or scrolling behavior, use the MarkdownBody instead:
new MarkdownBody(data: markdownSource);
By default, Markdown uses the formatting from the current material design theme, but it's possible to create your own custom styling. Use the MarkdownStyle class to pass in your own style. If you don't want to use Markdown outside of material design, use the MarkdownRaw class.
Img tag only supports the following image locations. It specifically
does not support image locations referring to bundled assets.
From the network: Use a URL prefixed by either
From local files on the device: Use an absolute path to the file, for example by
concatenating the file name with the path returned by a known storage location,
such as those provided by the
onTapcallback on images nested in hyperlinks
imageDirectoryproperty to specify the base directory containing the image files.
onTapcallback on hyperlinks
Add this to your package's pubspec.yaml file:
dependencies: flutter_markdown: ^0.1.2
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.2.0||Aug 21, 2018|
|0.1.6||Aug 1, 2018|
|0.1.5||Mar 28, 2018|
|0.1.3||Feb 20, 2018|
|0.1.2||Feb 20, 2018|
|0.1.1||Dec 22, 2017|
|0.1.0||Nov 7, 2017|
|0.0.9||May 4, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.19.0 <2.0.0|