flutter_markdown 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 48

Flutter Markdown

pub package Build Status

A markdown renderer for Flutter. It supports the original format, but no inline html.

Getting Started

Using the Markdown widget is simple, just pass in the source markdown as a string:

new Markdown(data: markdownSource);

If you do not want the padding or scrolling behavior, use the MarkdownBody instead:

new MarkdownBody(data: markdownSource);

By default, Markdown uses the formatting from the current material design theme, but it's possible to create your own custom styling. Use the MarkdownStyle class to pass in your own style. If you don't want to use Markdown outside of material design, use the MarkdownRaw class.

Image support

The Img tag only supports the following image locations. It specifically does not support image locations referring to bundled assets.

  • From the network: Use a URL prefixed by either http:// or https://.

  • From local files on the device: Use an absolute path to the file, for example by concatenating the file name with the path returned by a known storage location, such as those provided by the path_provider plugin.

0.1.2

  • Add support for horizontal rules.
  • Fix the onTap callback on images nested in hyperlinks

0.1.1

  • Add support for local file paths in image links. Make sure to set the imageDirectory property to specify the base directory containing the image files.

0.1.0

  • Roll the dependency on markdown to 1.0.0
  • Add a test and example for image links
  • Fix the onTap callback on hyperlinks

0.0.9

  • First published version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_markdown: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_markdown/flutter_markdown.dart';
  
Version Uploaded Documentation Archive
0.2.0 Aug 21, 2018 Go to the documentation of flutter_markdown 0.2.0 Download flutter_markdown 0.2.0 archive
0.1.6 Aug 1, 2018 Go to the documentation of flutter_markdown 0.1.6 Download flutter_markdown 0.1.6 archive
0.1.5 Mar 28, 2018 Go to the documentation of flutter_markdown 0.1.5 Download flutter_markdown 0.1.5 archive
0.1.3 Feb 20, 2018 Go to the documentation of flutter_markdown 0.1.3 Download flutter_markdown 0.1.3 archive
0.1.2 Feb 20, 2018 Go to the documentation of flutter_markdown 0.1.2 Download flutter_markdown 0.1.2 archive
0.1.1 Dec 22, 2017 Go to the documentation of flutter_markdown 0.1.1 Download flutter_markdown 0.1.1 archive
0.1.0 Nov 7, 2017 Go to the documentation of flutter_markdown 0.1.0 Download flutter_markdown 0.1.0 archive
0.0.9 May 4, 2017 Go to the documentation of flutter_markdown 0.0.9 Download flutter_markdown 0.0.9 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
96
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0