flutter_midi 0.2.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 89

flutter_midi #

A FLutter Plugin to Play midi on iOS and Android. This uses SoundFont (.sf2) Files.

Instalation #

Download a sound font file, example: sound_font.SF2 file here.

Create an /assets folder and store the .sf2 files

Update pubspec.yaml

assets:
   - assets/sf2/Piano.SF2
   - assets/sf2/SmallTimGM6mb.sf2

Load the sound font to prepare to play;

 @override
  void initState() {
    load('assets/sf2/Piano.SF2');
    super.initState();
  }
  
 void load(String asset) async {
    FlutterMidi.unmute(); // Optionally Unmute
    ByteData _byte = await rootBundle.load(asset);
    FlutterMidi.prepare(sf2: _byte);
  }

Play and Stop the Midi Notes

 FlutterMidi.playMidiNote(midi: 60);

 FlutterMidi.stopMidiNote(midi: 60);

0.2.0 - 04.06.2019 #

  • Updating Example to be desktop aware

0.1.1 #

  • Added Ability to Change .sf2 File Being Played
  • Updated Example

0.1.0 #

  • Removed Need to Bundle .sf2 on iOS
  • Added .sf2 Support for Android
  • Added Ability to Cancel any note for true polyphony
  • Updated Example
  • Changed way SoundFont is Loaded (From Asset Folder)

0.0.4 #

  • Fixing Android Bug
  • Added Midi to Android

0.0.2 #

  • Optional force unmute

0.0.1 #

  • Added Midi for iOS.

example/README.md

flutter_midi_example #

Demonstrates how to use the flutter_midi plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_midi: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_midi/flutter_midi.dart';
  
Version Uploaded Documentation Archive
0.2.0 Apr 6, 2019 Go to the documentation of flutter_midi 0.2.0 Download flutter_midi 0.2.0 archive
0.1.1+3 Feb 20, 2019 Go to the documentation of flutter_midi 0.1.1+3 Download flutter_midi 0.1.1+3 archive
0.1.1+2 Feb 19, 2019 Go to the documentation of flutter_midi 0.1.1+2 Download flutter_midi 0.1.1+2 archive
0.1.1+1 Feb 7, 2019 Go to the documentation of flutter_midi 0.1.1+1 Download flutter_midi 0.1.1+1 archive
0.1.1 Jan 30, 2019 Go to the documentation of flutter_midi 0.1.1 Download flutter_midi 0.1.1 archive
0.1.0 Jan 29, 2019 Go to the documentation of flutter_midi 0.1.0 Download flutter_midi 0.1.0 archive
0.0.4 Oct 24, 2018 Go to the documentation of flutter_midi 0.0.4 Download flutter_midi 0.0.4 archive
0.0.3 Oct 21, 2018 Go to the documentation of flutter_midi 0.0.3 Download flutter_midi 0.0.3 archive
0.0.2 Sep 25, 2018 Go to the documentation of flutter_midi 0.0.2 Download flutter_midi 0.0.2 archive
0.0.1 Sep 24, 2018 Go to the documentation of flutter_midi 0.0.1 Download flutter_midi 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
81
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
89
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on Apr 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
path_provider ^0.5.0+1 0.5.0+1
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8