flutter_mobilepay_payment 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 76

pub package

Flutter MobilePay payment

A Flutter plugin for integrating Scandinavian payment provider MobilePay.

Only Android support for now.

Usage

Install the package by adding the line flutter_mobilepay_payment: ^0.1.0 to pubspec.yaml and run flutter packages get.

Import it in main.dart;

import 'package:flutter_mobilepay_payment/flutter_mobilepay_payment.dart';

and once in your app, initialize a AppSwitchPayment instance:

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  static AppSwitchPayment _mobilePay = AppSwitchPayment(
      "APPDK0000000000", Country.Denmark,
      captureType: CaptureType.Reserve);

  @override
  _MyAppState createState() => _MyAppState(_mobilePay);
}

Then do a payment like this:

final payment = await mobilePay.pay("86715c57-8840-4a6f-af5f-07ee89107ece", 10.0);

If payment is null, that means that the payment was cancelled, i.e. the user backed out. If an error occurs, an exception will be thrown with the corresponding error code. Otherwise, the payment object will contain the paid amount and the transaction ID.

At this point you would want to process the payment, e.g. by sending the order ID and transaction ID to your backend. When the process completes succesfully, call

await payment.complete();

If the app fails to process the payment, or even if it crashes after returning from AppSwitch, the uncompleted payment will be accessible through

final payment = await incompletePayment();

You should check for that when your app starts, and if it is non-null, resume the app in the state where it is processing the payment.

MobilePay

The plugin has MobilePay AppSwitch SDK v. 1.8.1 built in. See here if it's the latest one.

Troubleshooting

Q: I got a lovely java.lang.AbstractMethodError (no error message) from gradle after installing the package. A: That's been seen when using Kotlin 1.2.50, and it was fixed by upgrading to 1.2.60.

Flutter

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1

First release. Android support only.

0.1.0

Robustness by marking payment processing complete and ability to detect and resume uncompleted payments.

0.1.1

Update to Flutter v.0.10.

example/README.md

flutter_mobilepay_payment_example

Demonstrates how to use the flutter_mobilepay_payment plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_mobilepay_payment: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_mobilepay_payment/flutter_mobilepay_payment.dart';
  
Version Uploaded Documentation Archive
0.1.1 Nov 12, 2018 Go to the documentation of flutter_mobilepay_payment 0.1.1 Download flutter_mobilepay_payment 0.1.1 archive
0.1.0 Oct 26, 2018 Go to the documentation of flutter_mobilepay_payment 0.1.0 Download flutter_mobilepay_payment 0.1.0 archive
0.0.2 Aug 31, 2018 Go to the documentation of flutter_mobilepay_payment 0.0.2 Download flutter_mobilepay_payment 0.0.2 archive
0.0.1 Aug 20, 2018 Go to the documentation of flutter_mobilepay_payment 0.0.1 Download flutter_mobilepay_payment 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
53
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8