flutter_multiselect 0.2.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 91

flutter_multiselect #

Flutter package for multi-select UI widget

Getting Started #

add package in your pubspec.yaml flutter_multiselect: 0.0.1

and import in your project to start using the multiselect.

By default, there is no UI contro for multi-select in iOS and Android

This widget can be used for bridge that gap.

Sample Usage -

new MultiSelect( autovalidate: false, titleText: title, validator: (value) { if (value == null) { return 'Please select one or more option(s)'; } }, errorText: 'Please select one or more option(s)', dataSource: [ { "display": "Australia", "value": 1, }, { "display": "Canada", "value": 1, }, { "display": "India", "value": 3, }, { "display": "United States", "value": 4, }], textField: 'display', valueField: 'value', filterable: true, required: true, value: null, onSaved: (value) { print('The value is $value'); });

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

0.2.0 Jan 17, 2019 test cases updates & bug fixes 0.1.1 Jan 17, 2019 Fixed formatting issues 0.1.0 Jan 9, 2019 Updated the YAML file with description and version number & updated examples 0.0.2 Dec 6, 2018 * Bug fixes * 0.0.1 Dec 6, 2018 *** Initial Code checkin ***

example/README.md

multiselect_example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_multiselect: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_multiselect/flutter_multiselect.dart';
  
Version Uploaded Documentation Archive
0.2.0 Mar 26, 2019 Go to the documentation of flutter_multiselect 0.2.0 Download flutter_multiselect 0.2.0 archive
0.1.1 Jan 17, 2019 Go to the documentation of flutter_multiselect 0.1.1 Download flutter_multiselect 0.1.1 archive
0.1.0 Jan 9, 2019 Go to the documentation of flutter_multiselect 0.1.0 Download flutter_multiselect 0.1.0 archive
0.0.2 Dec 6, 2018 Go to the documentation of flutter_multiselect 0.0.2 Download flutter_multiselect 0.0.2 archive
0.0.1 Dec 6, 2018 Go to the documentation of flutter_multiselect 0.0.1 Download flutter_multiselect 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
81
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
91
Learn more about scoring.

We analyzed this package on Apr 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^4.0.0