flutter_nowplaying_plugin 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 52

flutter_nowplaying_plugin

Flutte now playing plugin. Current Support Android and Google Play Music App.

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/lib/main.dart

import 'dart:io' show Platform;

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:flutter_nowplaying_plugin/flutter_nowplaying_plugin.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  Track _track = new Track.empty();

  @override
  initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  initPlatformState() async {
    Track track = new Track.empty();
    if (Platform.isAndroid) {
      try {
        track = await FlutterNowplayingPlugin.currentTrack;
        if (!mounted) return;
      } on PlatformException {}
      setState(() {
        _track = track;
      });
    }
  }

  updateCurrentTrack() async {
    Track track = new Track.empty();
    // Platform messages may fail, so we use a try/catch PlatformException.
    if (Platform.isAndroid) {
      try {
        track = await FlutterNowplayingPlugin.currentTrack;
      } on PlatformException {}
    }
    setState(() {
      _track = track;
    });
  }

  @override
  Widget build(BuildContext context) {
    print(_track.title);
    print(_track.album);
    print(_track.artist);
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        ),
        body: new Center(
            child: new Text(
                'Title: ${_track.title.trim()}\nAlbum: ${_track
                    .album.trim()}\nArtist: ${_track.artist.trim()}',
                style: new TextStyle(fontSize: 18.0))
        ),
        floatingActionButton: new FloatingActionButton(
            onPressed: updateCurrentTrack,
            tooltip: "Update Current Track",
            child: new Icon(Icons.update)),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_nowplaying_plugin: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:flutter_nowplaying_plugin/flutter_nowplaying_plugin.dart';
  
Version Uploaded Documentation Archive
0.0.1 Apr 2, 2018 Go to the documentation of flutter_nowplaying_plugin 0.0.1 Download flutter_nowplaying_plugin 0.0.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3
  • Flutter: 0.5.4

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
13 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
52
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Suggestions

  • Fix dependencies in pubspec.yaml.

    Running flutter packages pub upgrade failed with the following output:

    ERR: The current Dart SDK version is 2.0.0-dev.60.0.flutter-a5e41681e5.
     
     Because flutter_nowplaying_plugin requires SDK version >=2.0.0-dev43.0 <2.0.0, version solving failed.
    
  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Fix dependencies in pubspec.yaml.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev43.0 <2.0.0