flutter_oauth 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 41

Flutter OAuth

A flutter oauth package for performing user authentication for your apps.

I've tested this with a small collection of APIs (Buffer, Strava, Unsplash and Github). If there is an issue with an API you are trying to work with, please file an issue :)

Authorizing an application

Performing authorization for an API is straight forward using this library. In most cases you will just be able to use the following approach:

final OAuth flutterOAuth = new FlutterOAuth(new Config( "https://unsplash.com/oauth/authorize", "https://unsplash.com/oauth/token", "YOUR_CLIENT_ID", "YOUR_CLIENT_SECRET", "http://localhost:8080", "code"));

This allows you to pass in an Authorization URL, Token request URL, Client ID, Client Secret, Redirect URL and the response type. This should satisfy most requests, but if not then you can pass in other optional parameters for:

contentType - This allows you to change the content type for the request. Fr example, for Spotify API authorization you need to use "application/x-www-form-urlencoded"

final OAuth flutterOAuth = new FlutterOAuth(new Config( ..., contentType: "application/x-www-form-urlencoded"));

parameters - Add your own parameters that this library may not support out-of-the-box. For example, with the github API you can send a state string and scopes to gain authorization for

Map<String, String> customParameters = {"state": "SOME_RANDOM_SECURE_STRING", "scope": "public_repo"};

final OAuth flutterOAuth = new FlutterOAuth(new Config( ..., parameters: customParameters));

headers - Some APIs require you to send custom headers, such as an Authorization Header. Use this parameter if you require this

Map<String, String> headers = {"Authorization": "Basic SOME_BASE_64_STRING"};

final OAuth flutterOAuth = new FlutterOAuth(new Config( ..., headers: headers));

Token token = await gitterOAuth.signIn(); String accessToken = token.accessToken;

Thanks to

Kevin Seqaud for his awesome blog post on Flutter OAuth https://medium.com/@segaud.kevin/facebook-oauth-login-flow-with-flutter-9adb717c9f2e

THe auther, Hadrien Lejard, behind the:

The Gitter-Dart repo, where a lot of this library was influenced from https://github.com/dart-flitter/gitter_dart

and the Flutter Webview plugin which this library uses https://github.com/dart-flitter/flutter_webview_plugin

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_oauth: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_oauth/lib/auth_code_information.dart';
import 'package:flutter_oauth/lib/flutter_auth.dart';
import 'package:flutter_oauth/lib/model/config.dart';
import 'package:flutter_oauth/lib/oauth.dart';
import 'package:flutter_oauth/lib/oauth_token.dart';
import 'package:flutter_oauth/lib/token.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 8, 2017 Go to the documentation of flutter_oauth 0.0.1 Download flutter_oauth 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
81
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0