Flutter Plugin Tools implements a CLI with various productivity tools for hosting multiple Flutter plugins in one github repository. It is mainly used by the flutter/plugins and flutter/flutterfire repositories. It was mainly written to facilitate testing on Travis for these repositories (see travis.yaml).
As an example, Flutter Plugin Tools allows you to:
In order to use the tools you need to enable them once by running the following command:
$ pub global activate flutter_plugin_tools
To use all features of
flutter_plugin_tools you'll need the following commands in your
pub(recommended: version from
clang-formatversion 5 (alternatively, you can provide the path via
$ pub global run flutter_plugin_tools <command>
help to print a list of available commands.
Add this to your package's pubspec.yaml file:
dependencies: flutter_plugin_tools: "^0.0.7"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
|0.0.7||Apr 12, 2018|
|0.0.5||Jul 7, 2017|
|0.0.4||Jun 14, 2017|
|0.0.3||Jun 8, 2017|
|0.0.2||May 24, 2017|
|0.0.1||May 15, 2017|
|0.0.1-dev1||May 12, 2017|
|0.0.1-dev||May 12, 2017|
We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, web, other
No platform restriction found in libraries.
Changelog entries help clients to follow the progress in your code.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.8.0 <2.0.0|