flutter_radio 0.1.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 80

flutter_radio #

A Flutter audio plugin for Android to play remote audio files using ExoPlayer

pub package

Installation #

First, add flutter_radio as a dependency in your pubspec.yaml file.

Example #

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter_radio/flutter_radio.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {

  String url = "https://ia802708.us.archive.org/3/items/count_monte_cristo_0711_librivox/count_of_monte_cristo_001_dumas.mp3";

  @override
  void initState() {
    super.initState();
    audioStart();
  }

  Future<void> audioStart() async {
    await FlutterRadio.audioStart();
    print('Audio Start OK');
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Audio Plugin Android'),
        ),
        body: new Center(
          child: Column(
            children: <Widget>[
              FlatButton(
                child: Icon(Icons.play_circle_filled),
                onPressed: () => FlutterRadio.play(url: url),
              ),
              FlatButton(
                child: Icon(Icons.pause_circle_filled),
                onPressed: () => FlutterRadio.pause(),
              )
            ],
          )
        ),
      ),
    );
  }
}

0.0.1 #

  • TODO: Describe initial release.

example/README.md

flutter_radio_example #

Demonstrates how to use the flutter_radio plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_radio: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_radio/flutter_radio.dart';
  
Version Uploaded Documentation Archive
0.1.2 Feb 6, 2019 Go to the documentation of flutter_radio 0.1.2 Download flutter_radio 0.1.2 archive
0.1.1 Jan 30, 2019 Go to the documentation of flutter_radio 0.1.1 Download flutter_radio 0.1.1 archive
0.1.0 Sep 1, 2018 Go to the documentation of flutter_radio 0.1.0 Download flutter_radio 0.1.0 archive
0.0.4 Dec 14, 2018 Go to the documentation of flutter_radio 0.0.4 Download flutter_radio 0.0.4 archive
0.0.3 Aug 10, 2018 Go to the documentation of flutter_radio 0.0.3 Download flutter_radio 0.0.3 archive
0.0.2 Aug 9, 2018 Go to the documentation of flutter_radio 0.0.2 Download flutter_radio 0.0.2 archive
0.0.1 Aug 9, 2018 Go to the documentation of flutter_radio 0.0.1 Download flutter_radio 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
68
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
80
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

7 out of 7 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support the latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <=2.9.9
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8