flutter_reorderable_list 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new65

Reorderable List in Flutter

iOS-like proof of concept reorderable list with animations

Preview

Getting Started

See example/lib/main.dart for example usage

Highlights

  • Smooth reordering animations
  • Supports large lists (thousands of items)
  • Supports different item heights

Caveats

There are no API stability guarantees.

If you used previous version of reorderable list keep in mind that ReorderableListener now needs to be placed somewhere in ReorderableItem hierarchy in order to detect touch and trigger actual reordering (see the example).

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/README.md

Reorderable List in Flutter

iOS-like proof of concept reorderable list with animations

Preview

Getting Started

See lib/main.dart for example usage

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_reorderable_list: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_reorderable_list/flutter_reorderable_list.dart';
  
Version Uploaded Documentation Archive
0.1.1 Nov 25, 2018 Go to the documentation of flutter_reorderable_list 0.1.1 Download flutter_reorderable_list 0.1.1 archive
0.1.0 Nov 25, 2018 Go to the documentation of flutter_reorderable_list 0.1.0 Download flutter_reorderable_list 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test