flutter_responsive_cursor 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new49

Flutter Responsive Cursor #

About #

A replacement for Flutter's EditableText with native-like cursor behavior. The cursor stays on while typing and fades in and out rather than blinking.

Usage #

import 'package:flutter_responsive_cursor/flutter_responsive_cursor.dart';

var _controller = TextEditingController();

ResponsiveCursorEditableText(
    controller: _controller,
    cursorColor: Colors.lightBlue,
    focusNode: FocusNode(),
    style: Theme.of(context).textTheme.body1,
);

ResponsiveCursorTextField(
    cursorColor: Colors.lightBlue,
    style: Theme.of(context).textTheme.body1,
);

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/example.dart

import 'package:flutter/material.dart';
import 'package:flutter_responsive_cursor/flutter_responsive_cursor.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  var _controller = TextEditingController.fromValue(TextEditingValue(text: 'Hello'));

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            ResponsiveCursorEditableText(
              controller: _controller,
              cursorColor: Colors.lightBlue,
              focusNode: FocusNode(),
              style: Theme.of(context).textTheme.body1,
            ),
            ResponsiveCursorTextField(
              cursorColor: Colors.lightBlue,
              style: Theme.of(context).textTheme.body1,
            ),
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_responsive_cursor: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_responsive_cursor/flutter_responsive_cursor.dart';
  
Version Uploaded Documentation Archive
0.0.3 Mar 11, 2019 Go to the documentation of flutter_responsive_cursor 0.0.3 Download flutter_responsive_cursor 0.0.3 archive
0.0.2 Mar 5, 2019 Go to the documentation of flutter_responsive_cursor 0.0.2 Download flutter_responsive_cursor 0.0.2 archive
0.0.1 Mar 5, 2019 Go to the documentation of flutter_responsive_cursor 0.0.1 Download flutter_responsive_cursor 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
83
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Mar 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/flutter_responsive_cursor.dart. (-25 points)

Analysis of lib/flutter_responsive_cursor.dart failed with 1 error:

line 397 col 7: Missing concrete implementation of TextInputClient.updateFloatingCursor.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
rxdart ^0.19.0 0.19.0 0.21.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test