flutter_scan_bluetooth 0.0.5

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new28

flutter_scan_bluetooth

Flutter plugin to scan Bluetooth devices.

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1

  • TODO: Describe initial release.

example/lib/main.dart

import 'dart:async';

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:flutter_scan_bluetooth/flutter_scan_bluetooth.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _data = '';
  bool _scanning = false;

  @override
  void initState() {
    super.initState();

    FlutterScanBluetooth.devices.listen((device) {
      setState(() {
        _data += device.name+'\n';
      });
    });
    FlutterScanBluetooth.scanStopped.listen((device) {
      setState(() {
        _scanning = false;
      });
    });
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Column(
          mainAxisAlignment: MainAxisAlignment.start,
          children: <Widget>[
            Expanded(child: Text(_data)),
            Padding(
              padding: const EdgeInsets.all(8.0),
              child: Center(
                child: RaisedButton(child: Text(_scanning ? 'Stop scan' : 'Start scan'), onPressed: () async {
                  try {
                    if(_scanning) {
                      await FlutterScanBluetooth.stopScan;
                      debugPrint("scanning stoped");
                    }
                    else {
                      await FlutterScanBluetooth.startScan(pairedDevices: true);
                      debugPrint("scanning started");
                    }
                    setState(() {
                      if(!_scanning) {
                        _data = '';
                      }
                      _scanning = !_scanning;
                    });
                  } on PlatformException catch (e) {
                    debugPrint(e.toString());
                  }
                }),
              ),
            )
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_scan_bluetooth: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_scan_bluetooth/flutter_scan_bluetooth.dart';
  
Version Uploaded Documentation Archive
0.0.5 Aug 3, 2018 Go to the documentation of flutter_scan_bluetooth 0.0.5 Download flutter_scan_bluetooth 0.0.5 archive
0.0.4 Aug 3, 2018 Go to the documentation of flutter_scan_bluetooth 0.0.4 Download flutter_scan_bluetooth 0.0.4 archive
0.0.3 Aug 3, 2018 Go to the documentation of flutter_scan_bluetooth 0.0.3 Download flutter_scan_bluetooth 0.0.3 archive
0.0.2 Aug 2, 2018 Go to the documentation of flutter_scan_bluetooth 0.0.2 Download flutter_scan_bluetooth 0.0.2 archive
0.0.1 Aug 2, 2018 Go to the documentation of flutter_scan_bluetooth 0.0.1 Download flutter_scan_bluetooth 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0