flutter_speed_dialer 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 11

flutter_speed_dialer

A FAB Speed Dialer for flutter that actually works.

Taken verbatim from Collin Jackson's StackOverflow post.

Demo gif

Getting Started

Just add a SpeedDialer as your FAB within a scaffold, like this:

floatingActionButton:
    new SpeedDialer(children: modeButtons));

where you define the buttons that will pop out like this:

    List<Widget> modeButtons = [
      new SpeedDialerButton(backgroundColor: Colors.blue,
          icon: Icons.directions_bike, onPressed: () => print("Clicked"), text: "hi!")];

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - 3/29/2018

  • Initial release includes SpeedDialer and SpeedDialerButtons.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_speed_dialer: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_speed_dialer/flutter_speed_dialer.dart';
  
Version Uploaded Documentation Archive
0.0.2 Apr 15, 2018 Go to the documentation of flutter_speed_dialer 0.0.2 Download flutter_speed_dialer 0.0.2 archive
0.0.1 Mar 29, 2018 Go to the documentation of flutter_speed_dialer 0.0.1 Download flutter_speed_dialer 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
21
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
11
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <2.0.0