flutter_storey 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 7

flutter_storey

Build Status

Flutter binding to storey which is a redux-like store management but with hierarchical support.

Usages

See dartdocs for now.

License

Released under The MIT License (MIT). See LICENSE for the full license text.

Recommendations

0.1.1

  • Support storey 0.2.x

0.1.0

  • Fix mismatch path type to storey

0.0.3

  • Update storey version to 0.1.0

0.0.2

  • Fix missing child widget for StoreContainer
  • Document public API
  • Add tests
  • Add CI support

0.0.1

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_storey: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_storey/flutter_storey.dart';
  
Version Uploaded Documentation Archive
0.1.1 Dec 10, 2017 Go to the documentation of flutter_storey 0.1.1 Download flutter_storey 0.1.1 archive
0.1.0 Dec 9, 2017 Go to the documentation of flutter_storey 0.1.0 Download flutter_storey 0.1.0 archive
0.0.3 Dec 9, 2017 Go to the documentation of flutter_storey 0.0.3 Download flutter_storey 0.0.3 archive
0.0.2 Dec 8, 2017 Go to the documentation of flutter_storey 0.0.2 Download flutter_storey 0.0.2 archive
0.0.1 Dec 7, 2017 Go to the documentation of flutter_storey 0.0.1 Download flutter_storey 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
7
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0