flutter_stream_redux 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 52

flutter_stream_redux

Stream helper for build_redux and flutter_build_redux

Getting Started

  • soon

[0.0.2] - Feb. 28, 2018

  • moved subscription to didChangeDependencies

[0.0.1] - Feb. 27, 2018

  • initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_stream_redux: "^0.0.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:flutter_stream_redux/flutter_stream_redux.dart';
  
Version Uploaded Documentation Archive
0.0.4+1 Mar 1, 2018 Go to the documentation of flutter_stream_redux 0.0.4+1 Download flutter_stream_redux 0.0.4+1 archive
0.0.4 Mar 1, 2018 Go to the documentation of flutter_stream_redux 0.0.4 Download flutter_stream_redux 0.0.4 archive
0.0.3+1 Feb 28, 2018 Go to the documentation of flutter_stream_redux 0.0.3+1 Download flutter_stream_redux 0.0.3+1 archive
0.0.3 Feb 28, 2018 Go to the documentation of flutter_stream_redux 0.0.3 Download flutter_stream_redux 0.0.3 archive
0.0.2 Feb 28, 2018 Go to the documentation of flutter_stream_redux 0.0.2 Download flutter_stream_redux 0.0.2 archive
0.0.1 Feb 27, 2018 Go to the documentation of flutter_stream_redux 0.0.1 Download flutter_stream_redux 0.0.1 archive

Analysis

We analyzed this package on Jun 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3
  • Flutter: 0.5.2

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
13 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80 / 100
Overall score:
Weighted score of the above. [more]
52
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Suggestions

  • Fix dependencies in pubspec.yaml.

    Running flutter packages pub upgrade failed with the following output:

    ERR: The current Flutter SDK version is 0.5.2.
     
     Because flutter_stream_redux requires Flutter SDK version ^0.1.2, version solving failed.
    
  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Fix dependencies in pubspec.yaml.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use flutter_stream_redux.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 3 hints.

    Run flutter format to format lib/generated/i18n.dart.

    Run flutter format to format lib/src/stream_middleware.dart.

    Similar analysis of the following files failed:

    • lib/src/streamed_store_connector.dart (hint)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0