flutter_tab_bar_no_ripple 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 72

TabBarNoRipple #

Build Status <br /> Just tab bar of Flutter, without Ripple Effect <br /> <br />

How to use #

This widget has the same API as TabBar widget in Flutter TabBar API

0.0.1 #

  • initial release.

0.0.2 #

  • Update document and example

example/README.md

TabBarNoRipple #

This widget has the same API as TabBar widget in Flutter, without Ripple Effect

How to use #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_tab_bar_no_ripple: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_tab_bar_no_ripple/flutter_tab_bar_no_ripple.dart';
  
Version Uploaded Documentation Archive
0.1.1 Dec 26, 2018 Go to the documentation of flutter_tab_bar_no_ripple 0.1.1 Download flutter_tab_bar_no_ripple 0.1.1 archive
0.1.0 Dec 26, 2018 Go to the documentation of flutter_tab_bar_no_ripple 0.1.0 Download flutter_tab_bar_no_ripple 0.1.0 archive
0.0.3 Dec 25, 2018 Go to the documentation of flutter_tab_bar_no_ripple 0.0.3 Download flutter_tab_bar_no_ripple 0.0.3 archive
0.0.2 Dec 25, 2018 Go to the documentation of flutter_tab_bar_no_ripple 0.0.2 Download flutter_tab_bar_no_ripple 0.0.2 archive
0.0.1 Dec 25, 2018 Go to the documentation of flutter_tab_bar_no_ripple 0.0.1 Download flutter_tab_bar_no_ripple 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Feb 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test