flutter_unipay_plugin 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new46

flutter_unipay_plugin

License: MIT

根据银联手机控件支付的集成需要,为fluter平台开发一款能够实现基本功能的插件

使用说明

  • 请参考Flutter文档,了解plugin的一般用法
  • 本插件在iOS platform集成时,由于银联静态库存在C++/ObjC混编,因此需要在你的Flutter工程内使用到银联API的地方,使用ObjectC++混编,具体请参考example里的ios工程配置

欢迎支持

0.0.1

  • 2018-11-30 银联全渠道产品-手机控件支付集成的flutter插件,能够正常发起支付,并通过BinaryMessage向插件调用一端返回结果

example/README.md

flutter_unipay_plugin_example

Demonstrates how to use the flutter_unipay_plugin plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_unipay_plugin: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_unipay_plugin/flutter_unipay_plugin.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 7, 2018 Go to the documentation of flutter_unipay_plugin 0.0.1 Download flutter_unipay_plugin 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Dec 7, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Documentation URL does not exists. (-10 points)

We were unable to access https://github.com/delapecci/flutter_unipay_plugin/doc/api/index.html at the time of the analysis.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
dio ^1.0.9 1.0.9
flutter 0.0.0
Transitive dependencies
collection 1.14.11
cookie_jar 0.0.7
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8