flutter_update_version 0.0.20

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

flutter_update_version

Package to manage Flutter versioning.

Getting Started

This is a work in progress, not intended for use yet.

[0.0.1] - 04/16/2018

  • Initial release, test reading Android build.gradle

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_update_version: ^0.0.20

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.0.20 Apr 19, 2018 Go to the documentation of flutter_update_version 0.0.20 Download flutter_update_version 0.0.20 archive
0.0.19 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.19 Download flutter_update_version 0.0.19 archive
0.0.18 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.18 Download flutter_update_version 0.0.18 archive
0.0.17 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.17 Download flutter_update_version 0.0.17 archive
0.0.16 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.16 Download flutter_update_version 0.0.16 archive
0.0.15 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.15 Download flutter_update_version 0.0.15 archive
0.0.14 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.14 Download flutter_update_version 0.0.14 archive
0.0.13 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.13 Download flutter_update_version 0.0.13 archive
0.0.12 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.12 Download flutter_update_version 0.0.12 archive
0.0.11 Apr 16, 2018 Go to the documentation of flutter_update_version 0.0.11 Download flutter_update_version 0.0.11 archive

All 20 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0