flutter_util 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 36

flutter_util #

部分通用函数.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_util: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_util/flutter_util.dart';
  
Version Uploaded Documentation Archive
0.0.1 Nov 13, 2018 Go to the documentation of flutter_util 0.0.1 Download flutter_util 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
93
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1
  • Flutter: 1.2.1

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/tool.dart. (-5.36 points)

Analysis of lib/tool.dart reported 11 hints, including:

line 17 col 32: Avoid using unnecessary statements.

line 18 col 32: Avoid using unnecessary statements.

line 19 col 32: Avoid using unnecessary statements.

line 20 col 32: Avoid using unnecessary statements.

line 21 col 32: Avoid using unnecessary statements.

Fix lib/common.dart. (-1.49 points)

Analysis of lib/common.dart reported 3 hints:

line 1 col 8: Unused import: 'dart:async'.

line 21 col 14: Name non-constant identifiers using lowerCamelCase.

line 22 col 17: Name non-constant identifiers using lowerCamelCase.

Format lib/flutter_util.dart.

Run flutter format to format lib/flutter_util.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_util.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
intl ^0.15.5 0.15.7
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test