flutter_utils 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

flutter_utils

flutter common utils

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[0.0.1]

  • flutter common utils, it based on AndroidUtilCode on android platform, and Currently, ios platform is not supported.Support for ios will be added later.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:flutter_utils/flutter_utils.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _appVersionName = 'Unknown';
  String _appVersionCode = 'Unknown';
  String _androidId = 'Unknown';
  bool _isAppDebug = false;

  @override
  initState() {
    super.initState();
    initPlatformState();
  }

  initPlatformState() async {
    String appVersionName = 'Unknown';
    String appVersionCode = 'Unknown';
    String androidId = 'Unknown';
    bool isAppDebug = false;
    try {
      appVersionName = await FlutterUtils.appVersionName;
      appVersionCode = await FlutterUtils.appVersionCode;
      androidId = await FlutterUtils.androidId;
      isAppDebug = await FlutterUtils.isAppDebug;
    } on PlatformException {
      appVersionName = 'Failed to get platform version.';
      appVersionCode = 'Failed to get platform version.';
      androidId = 'Failed to get platform version.';
    }
    if (!mounted) return;

    setState(() {
      _appVersionName = appVersionName;
      _appVersionCode = appVersionCode;
      _androidId = androidId;
      _isAppDebug = isAppDebug;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: Text('Plugin example app'),
        ),
        body: Center(
          child: Column(
            mainAxisAlignment: MainAxisAlignment.center,
            children: <Widget>[
              Text('android id: $_androidId'),
              Text('app version name: $_appVersionName'),
              Text('app verison code: $_appVersionCode'),
              Text('app is debug: $_isAppDebug'),
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_utils: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_utils/flutter_utils.dart';
  
Version Uploaded Documentation Archive
0.0.1 May 12, 2018 Go to the documentation of flutter_utils 0.0.1 Download flutter_utils 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0