flutter_widgets 0.1.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 76

Flutter widgets #

Build Status

This repository contains the source code for various Flutter widgets that are developed by Google but not by the core Flutter team.

The Gallery sample application showcases the included Flutter widgets. To build it, first create the default Flutter project files:

cd gallery
flutter create .

and then it can be run with flutter run.

Issues #

Please file any issues, bugs, or feature requests in the this repo.

Contributing #

If you wish to contribute a change to any of the existing widgets in this repo, please review our contribution guide, and send a pull request.

0.1.0 #

Initial release featuring:

  • html_widget: Limited support for rendering HTML as flutter widgets. currently supports the following tags: div - br - table - b - u - a - font - hr - text

  • tagged_text: Support for styling text using custom HTML-like tags. This is particularly useful for styling text within a translated string.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_widgets: ^0.1.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_widgets/flutter_widgets.dart';
  
Version Uploaded Documentation Archive
0.1.3 Mar 14, 2019 Go to the documentation of flutter_widgets 0.1.3 Download flutter_widgets 0.1.3 archive
0.1.2 Feb 11, 2019 Go to the documentation of flutter_widgets 0.1.2 Download flutter_widgets 0.1.2 archive
0.1.0 Nov 28, 2018 Go to the documentation of flutter_widgets 0.1.0 Download flutter_widgets 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
59
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Apr 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/visibility_detector/demo.dart. (-3.45 points)

Analysis of lib/src/visibility_detector/demo.dart reported 7 hints, including:

line 42 col 44: Avoid using braces in interpolation when not needed.

line 42 col 51: Avoid using braces in interpolation when not needed.

line 143 col 27: Avoid using braces in interpolation when not needed.

line 143 col 39: Avoid using braces in interpolation when not needed.

line 271 col 33: Avoid using braces in interpolation when not needed.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_widgets.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
collection ^1.14.5 1.14.11
flutter 0.0.0
html ^0.13.2+2 0.13.4+2 0.14.0+2
intl ^0.15.2 0.15.8
meta ^1.1.1 1.1.6 1.1.7
quiver ^2.0.0+1 2.0.3
Transitive dependencies
charcode 1.1.2
csslib 0.15.0 0.16.0
matcher 0.12.5
path 1.6.2
sky_engine 0.0.99
source_span 1.5.5
stack_trace 1.9.3
term_glyph 1.1.0
typed_data 1.1.6
utf 0.9.0+5
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^3.0.0
test ^1.3.0