flutter_youtube 1.1.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 89

flutter_youtube

Flutter Plugin to play youtube Videos using youtube player api (android)

Supported

  • Android
  • iOS

How to Use

dependencies:
  flutter_youtube: "^1.1.4"

###Imports

import 'package:flutter_youtube/flutter_youtube.dart';

###Code

var youtube = new FlutterYoutube();

youtube.playYoutubeVideoByUrl(
  apiKey: "<API_KEY>",
  videoUrl: "<Youtube Video URL>",
  autoPlay: true, //default falase
  fullScreen: true //default false
);
FlutterYoutube.playYoutubeVideoById(
  apiKey: "<API_KEY>",
  videoId: "<Youtube Video ID>",
  autoPlay: true, //default falase
  fullScreen: true //default false
);

Video End Listener

*Note Right now only supported in android

youtube.onVideoEnded.listen((onData) {
  //perform your action when video playing is done
});
KeyValue
apiKeyString (Not Null)
videoUrlString (Not Null)
videoIdString (Not Null)
autoPlayBoolean (Optional)(Default = false)
fullScreenBoolean (Optional)(Default = false)

[1.1.4]

  • Broken ';' fixed

[1.1.3]

[1.1.2]

  • Video play complete listener Crash fixed

[1.1.1]

  • Youtube embed URL
  • Video AutoPlay
  • Video play complete listener

[1.0.1]

  • Bug fixes (video pause when screen rotated)

[1.0.0]

  • iOS Support added

[0.1.1] - 17-04-2018

  • Minor BugFixes

[0.1.1] - 17-04-2018

  • BugFixes

[0.1.0] - 17-04-2018

  • Initial Release
  • Play youtube video using url or by video id
  • setFullScreen

example/README.md

flutter_youtube_example

Demonstrates how to use the flutter_youtube plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_youtube: ^1.1.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_youtube/flutter_youtube.dart';
  
Version Uploaded Documentation Archive
1.1.4 Nov 8, 2018 Go to the documentation of flutter_youtube 1.1.4 Download flutter_youtube 1.1.4 archive
1.1.3 Nov 6, 2018 Go to the documentation of flutter_youtube 1.1.3 Download flutter_youtube 1.1.3 archive
1.1.2 Oct 16, 2018 Go to the documentation of flutter_youtube 1.1.2 Download flutter_youtube 1.1.2 archive
1.1.1 Aug 11, 2018 Go to the documentation of flutter_youtube 1.1.1 Download flutter_youtube 1.1.1 archive
1.1.0 Aug 11, 2018 Go to the documentation of flutter_youtube 1.1.0 Download flutter_youtube 1.1.0 archive
1.0.1 Jul 24, 2018 Go to the documentation of flutter_youtube 1.0.1 Download flutter_youtube 1.0.1 archive
1.0.0 Jul 24, 2018 Go to the documentation of flutter_youtube 1.0.0 Download flutter_youtube 1.0.0 archive
0.1.2 Apr 24, 2018 Go to the documentation of flutter_youtube 0.1.2 Download flutter_youtube 0.1.2 archive
0.1.1 Apr 17, 2018 Go to the documentation of flutter_youtube 0.1.1 Download flutter_youtube 0.1.1 archive
0.1.0 Apr 17, 2018 Go to the documentation of flutter_youtube 0.1.0 Download flutter_youtube 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
93
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-10 points)

8 out of 8 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
meta ^1.1.6 1.1.6
Transitive dependencies
collection 1.14.11
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8