fluttersteem 0.0.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

fluttersteem

Pub

A Flutter/Dart Steem client library. This library includes support for authentication (SteemConnect V2) as well as Broadcasting (vote, comment, follow ++) and data retrieval (using SteemJS to get followers, posts by users, users ++) .

Authentication

Via Access Token

If you already have an access token, you can authenticate a client.

Note: The user property of the SteemClient will be null.

var client = SteemApiAuth.authorizeViaAccessToken('<access-token>');
var me = await client.users.self.get();

SteemApiAuth

To perform authentication, use the SteemApiAuth class. All API scopes are included as SteemApiScope constants for convenience.

var auth = new SteemApiAuth('<client-id>', '<client-secret>',
  redirectUri: Uri.parse('<redirect-uri>'),
  scopes: [
    SteemApiScope.login,
    SteemApiScope.vote,
    // ...
  ]
);

Implicit Auth

Applications with no server-side component can implement implicit auth.

To get a redirect URI:

var redirectUri = auth.getImplicitRedirectUri();
window.location.href = redirectUri.toString();

After you have obtained an access token, use it to receive a SteemClient.

Endpoints

The SteemClient contains several getters that correspond to endpoints. Each is an abstraction over a specific Steem API.

Credits

This client library is written based on the code of instagram_dart

[0.0.7] - 06.03.2018

  • Still in pre-alpha
  • Still trying to fix '?' character in Uri causing an exception "invalid character"

[0.0.6] - 06.03.2018

  • Still in pre-alpha
  • Finally fixed error where '?' in Uri caused an exception "invalid character"

[0.0.5] - 06.03.2018

  • Still in pre-alpha
  • Fixed error where '?' in Uri created an exception "invalid character"

[0.0.4] - 05.03.2018

  • Updated documentation
  • Updated readme
  • Minor fixes

[0.0.3] - 05.03.2018

  • Removed code used in debugging
  • Minor fixes

[0.0.2] - 04.03.2018

  • Fixed issue where wrong API source was being used

[0.0.1] - 04.03.2018

  • Initial release: Client library for Steem
  • Using SteemConnect for Authentication (token-based) and Broadcasting (Vote, Comment, Follow ++)
  • SteemJS API for data retrieval

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fluttersteem: ^0.0.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fluttersteem/fluttersteem.dart';
  
Version Uploaded Documentation Archive
0.0.7 Mar 6, 2018 Go to the documentation of fluttersteem 0.0.7 Download fluttersteem 0.0.7 archive
0.0.6 Mar 6, 2018 Go to the documentation of fluttersteem 0.0.6 Download fluttersteem 0.0.6 archive
0.0.5 Mar 6, 2018 Go to the documentation of fluttersteem 0.0.5 Download fluttersteem 0.0.5 archive
0.0.4 Mar 5, 2018 Go to the documentation of fluttersteem 0.0.4 Download fluttersteem 0.0.4 archive
0.0.3 Mar 5, 2018 Go to the documentation of fluttersteem 0.0.3 Download fluttersteem 0.0.3 archive
0.0.2 Mar 4, 2018 Go to the documentation of fluttersteem 0.0.2 Download fluttersteem 0.0.2 archive
0.0.1 Mar 4, 2018 Go to the documentation of fluttersteem 0.0.1 Download fluttersteem 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0