A Flutter/Dart Steem client library. This library includes support for authentication (SteemConnect V2) as well as Broadcasting (vote, comment, follow ++) and data retrieval (using SteemJS to get followers, posts by users, users ++) .
If you already have an access token, you can authenticate a client.
user property of the
SteemClient will be
var client = SteemApiAuth.authorizeViaAccessToken('<access-token>'); var me = await client.users.self.get();
To perform authentication, use the
SteemApiAuth class. All API scopes are
SteemApiScope constants for convenience.
var auth = new SteemApiAuth('<client-id>', '<client-secret>', redirectUri: Uri.parse('<redirect-uri>'), scopes: [ SteemApiScope.login, SteemApiScope.vote, // ... ] );
Applications with no server-side component can implement implicit auth.
To get a redirect URI:
var redirectUri = auth.getImplicitRedirectUri(); window.location.href = redirectUri.toString();
After you have obtained an access token, use it to receive a
SteemClient contains several getters that correspond to endpoints. Each is an abstraction over
a specific Steem API.
This client library is written based on the code of instagram_dart
Add this to your package's pubspec.yaml file:
dependencies: fluttersteem: ^0.0.7
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.7||Mar 6, 2018|
|0.0.6||Mar 6, 2018|
|0.0.5||Mar 6, 2018|
|0.0.4||Mar 5, 2018|
|0.0.3||Mar 5, 2018|
|0.0.2||Mar 4, 2018|
|0.0.1||Mar 4, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.22.0 <2.0.0|