fluttersteem 0.0.7

  • README.md
  • Installing
  • Versions
  • new57



A Flutter/Dart Steem client library. This library includes support for authentication (SteemConnect V2) as well as Broadcasting (vote, comment, follow ++) and data retrieval (using SteemJS to get followers, posts by users, users ++) .


Via Access Token

If you already have an access token, you can authenticate a client.

Note: The user property of the SteemClient will be null.

var client = SteemApiAuth.authorizeViaAccessToken('<access-token>');
var me = await client.users.self.get();


To perform authentication, use the SteemApiAuth class. All API scopes are included as SteemApiScope constants for convenience.

var auth = new SteemApiAuth('<client-id>', '<client-secret>',
  redirectUri: Uri.parse('<redirect-uri>'),
  scopes: [
    // ...

Implicit Auth

Applications with no server-side component can implement implicit auth.

To get a redirect URI:

var redirectUri = auth.getImplicitRedirectUri();
window.location.href = redirectUri.toString();

After you have obtained an access token, use it to receive a SteemClient.


The SteemClient contains several getters that correspond to endpoints. Each is an abstraction over a specific Steem API.


This client library is written based on the code of instagram_dart

[0.0.7] - 06.03.2018

  • Still in pre-alpha
  • Still trying to fix '?' character in Uri causing an exception "invalid character"

[0.0.6] - 06.03.2018

  • Still in pre-alpha
  • Finally fixed error where '?' in Uri caused an exception "invalid character"

[0.0.5] - 06.03.2018

  • Still in pre-alpha
  • Fixed error where '?' in Uri created an exception "invalid character"

[0.0.4] - 05.03.2018

  • Updated documentation
  • Updated readme
  • Minor fixes

[0.0.3] - 05.03.2018

  • Removed code used in debugging
  • Minor fixes

[0.0.2] - 04.03.2018

  • Fixed issue where wrong API source was being used

[0.0.1] - 04.03.2018

  • Initial release: Client library for Steem
  • Using SteemConnect for Authentication (token-based) and Broadcasting (Vote, Comment, Follow ++)
  • SteemJS API for data retrieval

1. Depend on it

Add this to your package's pubspec.yaml file:

  fluttersteem: "^0.0.7"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:fluttersteem/fluttersteem.dart';
Version Uploaded Documentation Archive
0.0.7 Mar 6, 2018 Go to the documentation of fluttersteem 0.0.7 Download fluttersteem 0.0.7 archive
0.0.6 Mar 6, 2018 Go to the documentation of fluttersteem 0.0.6 Download fluttersteem 0.0.6 archive
0.0.5 Mar 6, 2018 Go to the documentation of fluttersteem 0.0.5 Download fluttersteem 0.0.5 archive
0.0.4 Mar 5, 2018 Go to the documentation of fluttersteem 0.0.4 Download fluttersteem 0.0.4 archive
0.0.3 Mar 5, 2018 Go to the documentation of fluttersteem 0.0.3 Download fluttersteem 0.0.3 archive
0.0.2 Mar 4, 2018 Go to the documentation of fluttersteem 0.0.2 Download fluttersteem 0.0.2 archive
0.0.1 Mar 4, 2018 Go to the documentation of fluttersteem 0.0.1 Download fluttersteem 0.0.1 archive


We analyzed this package on Mar 6, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.31.0
  • pana: 0.10.3


Describes how popular the package is relative to other packages. [more]
19 / 100
Code health derived from static analysis. [more]
93 / 100
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:fluttersteem/fluttersteem.dart with components: io.


  • Fix issues reported by dartanalyzer or dartfmt.

    dartanalyzer or dartfmt reported 3 warnings 29 hints.

    Strong-mode analysis of lib/src/models/models.json.g.dart gave the following warning:

    line: 490 col: 15
    A function of type '(Map<String, dynamic>) → Beneficiary' can't be assigned to a location of type '(dynamic) → Beneficiary'.

    Run dartfmt to format lib/fluttersteem.dart.

    Similar analysis of the following files failed:

    • lib/src/api/api.dart (hint)
    • lib/src/api/category.dart (hint)
    • lib/src/api/post.dart (hint)
    • lib/src/api/relationship.dart (hint)
    • lib/src/api/reply.dart (hint)
    • lib/src/api/steem.dart (hint)
    • lib/src/api/tag.dart (hint)
    • lib/src/api/user.dart (hint)
    • lib/src/api/vote.dart (hint)
    • lib/src/endpoints.dart (hint)
    • lib/src/fluttersteem.dart (hint)
    • lib/src/impl/category.dart (hint)
    • lib/src/impl/post.dart (hint)
    • lib/src/impl/relationship.dart (hint)
    • lib/src/impl/reply.dart (hint)
    • lib/src/impl/steem.dart (hint)
    • lib/src/impl/tag.dart (hint)
    • lib/src/impl/user.dart (hint)
    • lib/src/impl/vote.dart (hint)
    • lib/src/models/impl_models.dart (hint)
    • lib/src/models/models.dart (hint)
    • lib/src/requestor.dart (hint)
    • lib/src/scopes.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use fluttersteem.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0
oauth2 ^1.0.0 1.1.0
owl ^0.2.1 0.2.1+1
Transitive dependencies
async 2.0.6
charcode 1.1.1
collection 1.14.5
http 0.11.3+16
http_parser 3.1.1
path 1.5.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
build_runner ^0.3.0
owl_codegen ^0.2.1
test ^0.12.0