fluttery_cli 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

fluttery

A sample command-line application.

Created from templates made available by Stagehand under a BSD-style license.

0.0.1

  • Initial version, created by Stagehand

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate fluttery_cli

2. Use it

The package has the following executables:


$ fulltery

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fluttery_cli: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fluttery_cli/fluttery_cli.dart';
  
Version Uploaded Documentation Archive
0.1.2 Jun 23, 2018 Go to the documentation of fluttery_cli 0.1.2 Download fluttery_cli 0.1.2 archive
0.1.1 Jun 23, 2018 Go to the documentation of fluttery_cli 0.1.1 Download fluttery_cli 0.1.1 archive
0.1.0 Jun 23, 2018 Go to the documentation of fluttery_cli 0.1.0 Download fluttery_cli 0.1.0 archive
0.0.111 Jun 23, 2018 Go to the documentation of fluttery_cli 0.0.111 Download fluttery_cli 0.0.111 archive
0.0.12 Jun 23, 2018 Go to the documentation of fluttery_cli 0.0.12 Download fluttery_cli 0.0.12 archive
0.0.11 Jun 23, 2018 Go to the documentation of fluttery_cli 0.0.11 Download fluttery_cli 0.0.11 archive
0.0.10 Jun 23, 2018 Go to the documentation of fluttery_cli 0.0.10 Download fluttery_cli 0.0.10 archive
0.0.9 Jun 23, 2018 Go to the documentation of fluttery_cli 0.0.9 Download fluttery_cli 0.0.9 archive
0.0.8 Jun 23, 2018 Go to the documentation of fluttery_cli 0.0.8 Download fluttery_cli 0.0.8 archive
0.0.7 Jun 23, 2018 Go to the documentation of fluttery_cli 0.0.7 Download fluttery_cli 0.0.7 archive

All 16 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0