fly 0.0.3

  • Installing
  • Versions
  • 0


Best Flutter Framework for Beautiful Code and Programming Artisans.


The purpose of this framework is to encourage organized code, and break files up into their proper function.

This framework can work and be incorporated into any existing project! All you need to do is run the init command in the project directory.

We break up the project into 3 main directories.

  1. Services - contain logic that is used in multiple widgets.
  2. Styles - contains styles that are used in multiple widgets.
  3. Widgets - a directory that contains all the project's widgets

When creating a widget our CLI will automatically create the correct directory structure, break the widget into an organized set of files, and import the correct files needed to run.

It creates 3 files

  1. Style - contains that particular widget's styles
  2. View - contains the view and look of that widget
  3. Widget - contains that particular widget logic.

For Example:

if you create a widget called login



initilize existing project to work with existing commands

cd to/flutter/project
fly init

creats directories and files for the fly framework


Generate Widget

Create an additional widget. By default this will create a stateless widget

fly generate widget login


Create a Sateless Widget

fly generate widget:stateless login


gw: stands for "generate widget", this helps reduce time it takes to type out the full thing.

fly gw:stateless login

Create a Sateful Widget

fly generate widget:stateful login


fly gw:stateful login

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate fly

2. Use it

The package has the following executables:

$ fly
Version Uploaded Documentation Archive
0.0.3 Jul 30, 2018 Go to the documentation of fly 0.0.3 Download fly 0.0.3 archive
0.0.2 Jul 30, 2018 Go to the documentation of fly 0.0.2 Download fly 0.0.2 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 16, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7


Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because fly requires SDK version >=1.24.0 <=2.0.0, version solving failed.

Health suggestions

Format bin/file.dart.

Run dartfmt to format bin/file.dart.

Format bin/fly.dart.

Run dartfmt to format bin/fly.dart.

Format bin/helpers.dart.

Run dartfmt to format bin/helpers.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use fly.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <=2.0.0