fn_compose 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new39

fn_compose

Typed functional composition in Dart.

Examples

C(initial value).x(first function).x(second function).execute();
C(5).x(addOne).execute();

Todo / might do later

  • output a function
  • define just a function
  • Cannot implement the >> operator because operator generics are not possible in Dart at the moment

This is just a playful thing, nothing serious!

0.0.3

  • Update readme with todos

0.0.2

  • Update readme and fix an import naming bug

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fn_compose: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fn_compose/compose.dart';
import 'package:fn_compose/composefn.dart';
  
Version Uploaded Documentation Archive
0.0.3 Dec 5, 2018 Go to the documentation of fn_compose 0.0.3 Download fn_compose 0.0.3 archive
0.0.2 Dec 5, 2018 Go to the documentation of fn_compose 0.0.2 Download fn_compose 0.0.2 archive
0.0.1 Dec 5, 2018 Go to the documentation of fn_compose 0.0.1 Download fn_compose 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
39
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Health issues and suggestions

Document public APIs (-10 points)

13 out of 13 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Format lib/composefn.dart.

Run dartfmt to format lib/composefn.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use fn_compose.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
Dev dependencies
test ^1.0.0