This library contains a dart package useful to develop web-applications using
Font Awesome is a full suite of 675 pictographic icons for easy scalable vector graphics on websites, created and maintained by Dave Gandy. Stay up to date with the latest release and announcements on Twitter: @fontawesome.
Get started at http://fontawesome.io!
font_awesome dependency to your
dependencies: ... font_awesome: any ...
pub get and finally import it y your
<link rel="stylesheet" href="packages/font_awesome/css/font-awesome.min.css">
Font Awesome by Dave Gandy - http://fontawesome.io
Please read through our contributing guidelines. Included are directions for opening issues, coding standards, and notes on development.
Font Awesome will be maintained under the Semantic Versioning guidelines as much as possible. Releases will be numbered with the following format:
And constructed with the following guidelines:
For more information on SemVer, please visit http://semver.org.
Add this to your package's pubspec.yaml file:
dependencies: font_awesome: "^4.7.0"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
|4.7.0||Nov 16, 2017|
|4.6.3||Jul 4, 2016|
We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, web, other
Changelog entries help clients to follow the progress in your code.
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.19.0 <2.0.0|