fortune_1000_companies 0.1.0

  • Installing
  • Versions
  • 63

Fortune 1000 Companies

Pub Build Status

Just a list of fortune_1000_companies to be used for the greater good.


import 'package:fortune_1000_companies/fortune_1000_companies.dart';

main() {
  fortune_1000_companies.forEach(print); // A bunch of names...

  getRandomCompanyName(); // Safeway
  getRandomCompanyName(); // Walmart


fortune_1000_companies leverages the dart_dev package for most of its tooling needs, including static analysis, code formatting, running tests, collecting coverage, and serving examples. Check out the dart_dev readme for more information.

Testing - pub run dart_dev test

Formatting - pub run dart_dev format



  • Somehow another company snuck into the company list, @georgelesica-wf escorted him out.
  • Bumping to 0.1.0 to support ranges.


  • Initial version, created by Stagehand
  • List populated and ready to use.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  fortune_1000_companies: "^0.1.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:fortune_1000_companies/fortune_1000_companies.dart';
Version Uploaded Documentation Archive
0.1.0 Jan 10, 2017 Go to the documentation of fortune_1000_companies 0.1.0 Download fortune_1000_companies 0.1.0 archive
0.0.1 Sep 29, 2016 Go to the documentation of fortune_1000_companies 0.0.1 Download fortune_1000_companies 0.0.1 archive


We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
44 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
58 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:fortune_1000_companies/fortune_1000_companies.dart.


  • Package is getting outdated.

    The package was released 73 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use fortune_1000_companies.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
Dev dependencies
coverage ^0.7.2
dart_dev ^1.1.1
dart_style ^0.2.4
dartdoc >=0.8.0 <0.10.0
test ^0.12.4