fortune_1000_companies 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 3

Fortune 1000 Companies

Pub Build Status

Just a list of fortune_1000_companies to be used for the greater good.

Usage

import 'package:fortune_1000_companies/fortune_1000_companies.dart';

main() {
  fortune_1000_companies.forEach(print); // A bunch of names...

  getRandomCompanyName(); // Safeway
  getRandomCompanyName(); // Walmart
}

Development

fortune_1000_companies leverages the dart_dev package for most of its tooling needs, including static analysis, code formatting, running tests, collecting coverage, and serving examples. Check out the dart_dev readme for more information.

Testing - pub run dart_dev test

Formatting - pub run dart_dev format

Changelog

0.1.0

  • Somehow another company snuck into the company list, @georgelesica-wf escorted him out.
  • Bumping to 0.1.0 to support ranges.

0.0.1

  • Initial version, created by Stagehand
  • List populated and ready to use.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fortune_1000_companies: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fortune_1000_companies/fortune_1000_companies.dart';
  
Version Uploaded Documentation Archive
0.1.0 Jan 10, 2017 Go to the documentation of fortune_1000_companies 0.1.0 Download fortune_1000_companies 0.1.0 archive
0.0.1 Sep 29, 2016 Go to the documentation of fortune_1000_companies 0.0.1 Download fortune_1000_companies 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
6
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
3
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0