fpfantasy 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 60

Fp Fantasy

Fp style in the Dart 2!

Created from templates made available by Stagehand under a BSD-style license.

Usage

documentation

Features and bugs

Please file feature requests and bugs at the issue tracker.

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fpfantasy: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fpfantasy/fpfantasy.dart';
  
Version Uploaded Documentation Archive
1.0.0 Aug 16, 2018 Go to the documentation of fpfantasy 1.0.0 Download fpfantasy 1.0.0 archive
0.0.1 Aug 13, 2018 Go to the documentation of fpfantasy 0.0.1 Download fpfantasy 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
33
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:fpfantasy/fpfantasy.dart.

Suggestions

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use fpfantasy.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.67.0 <3.0.0
Dev dependencies
test ^1.3.0