front_end 0.1.1

  • Installing
  • Versions
  • 82

Front end for Dart

This package provides a low-level API for use by compiler back ends that wish to implement the Dart language. It is intended for eventual use by dev_compiler, dart2js, and the Dart VM. In addition, it will share implementation details with the analyzer package--this will be accomplished by having the analyzer package import (and re-export) parts of this package's private implementation.

End-users should use the [dartanalyzer][analyzercli] command-line tool to analyze their Dart code.

Integrators that want to write tools that analyze Dart code should use the [analyzer] package.

Note: The APIs in this package are in an early state; developers should be careful about depending on this package. In particular, there is no semver contract for release versions of this package. Please depend directly on individual versions.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  front_end: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.1.1 May 30, 2018 Go to the documentation of front_end 0.1.1 Download front_end 0.1.1 archive
0.1.0 May 14, 2018 Go to the documentation of front_end 0.1.0 Download front_end 0.1.0 archive
0.0.1 Oct 17, 2016 Go to the documentation of front_end 0.0.1 Download front_end 0.0.1 archive
0.1.0-alpha.12 Apr 30, 2018 Go to the documentation of front_end 0.1.0-alpha.12 Download front_end 0.1.0-alpha.12 archive
0.1.0-alpha.11 Mar 22, 2018 Go to the documentation of front_end 0.1.0-alpha.11 Download front_end 0.1.0-alpha.11 archive
0.1.0-alpha.10 Feb 14, 2018 Go to the documentation of front_end 0.1.0-alpha.10 Download front_end 0.1.0-alpha.10 archive
0.1.0-alpha.9 Feb 9, 2018 Go to the documentation of front_end 0.1.0-alpha.9 Download front_end 0.1.0-alpha.9 archive
0.1.0-alpha.8 Feb 2, 2018 Go to the documentation of front_end 0.1.0-alpha.8 Download front_end 0.1.0-alpha.8 archive
0.1.0-alpha.7 Nov 28, 2017 Go to the documentation of front_end 0.1.0-alpha.7 Download front_end 0.1.0-alpha.7 archive
0.1.0-alpha.6 Aug 25, 2017 Go to the documentation of front_end 0.1.0-alpha.6 Download front_end 0.1.0-alpha.6 archive

All 16 versions...


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
78 / 100
Code health derived from static analysis. [more]
99 / 100
Reflects how tidy and up-to-date the package is. [more]
63 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No libraries.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 32 errors 17 hints.

    Strong-mode analysis of lib/src/fasta/testing/kernel_chain.dart failed with the following error:

    line: 183 col: 12
    The method 'pass' isn't defined for the class 'WriteDill'.

    Strong-mode analysis of lib/src/fasta/testing/scanner_chain.dart failed with the following error:

    line: 31 col: 12
    The method 'pass' isn't defined for the class 'Scan'.

    Similar analysis of the following files failed:

    • lib/src/base/errors.dart (hint)
    • lib/src/base/jenkins_smi_hash.dart (hint)
    • lib/src/base/uri_kind.dart (hint)
    • lib/src/byte_store/protected_file_byte_store.dart (hint)
    • lib/src/codegen/tools.dart (hint)
    • lib/src/fasta/colors.dart (hint)
    • lib/src/fasta/deprecated_problems.dart (hint)
    • lib/src/fasta/kernel/body_builder.dart (hint)
    • lib/src/fasta/scanner/error_token.dart (hint)
    • lib/src/fasta/type_inference/type_schema.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use front_end.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48.0 <2.0.0
charcode ^1.1.1 1.1.1
convert ^2.0.1 2.0.1
crypto ^2.0.2 2.0.5
kernel 0.3.1 0.3.1
meta ^1.1.1 1.1.5
package_config ^1.0.1 1.0.3
path ^1.3.9 1.6.1
source_span ^1.2.3 1.4.0
yaml ^2.1.12 2.1.14
Transitive dependencies
collection 1.14.10
logging 0.11.3+1
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
analyzer >=0.31.0 <0.33.0
args >=0.13.0 <2.0.0 1.4.3
dart_style ^1.0.7
json_rpc_2 ^2.0.4
mockito ^2.0.2
stream_channel ^1.6.1
test ^0.12.0
test_reflective_loader ^0.1.0
web_socket_channel ^1.0.4