front_end 0.1.4

  • README.md
  • Installing
  • Versions
  • 47

Front end for Dart

This package provides a low-level API for use by compiler back ends that wish to implement the Dart language. It is intended for eventual use by dev_compiler, dart2js, and the Dart VM. In addition, it will share implementation details with the analyzer package--this will be accomplished by having the analyzer package import (and re-export) parts of this package's private implementation.

End-users should use the [dartanalyzer][analyzercli] command-line tool to analyze their Dart code.

Integrators that want to write tools that analyze Dart code should use the [analyzer] package.

Note: The APIs in this package are in an early state; developers should be careful about depending on this package. In particular, there is no semver contract for release versions of this package. Please depend directly on individual versions.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  front_end: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.1.4 Jul 20, 2018 Go to the documentation of front_end 0.1.4 Download front_end 0.1.4 archive
0.1.3 Jul 4, 2018 Go to the documentation of front_end 0.1.3 Download front_end 0.1.3 archive
0.1.2 Jun 26, 2018 Go to the documentation of front_end 0.1.2 Download front_end 0.1.2 archive
0.1.1 May 30, 2018 Go to the documentation of front_end 0.1.1 Download front_end 0.1.1 archive
0.1.0 May 14, 2018 Go to the documentation of front_end 0.1.0 Download front_end 0.1.0 archive
0.0.1 Oct 17, 2016 Go to the documentation of front_end 0.0.1 Download front_end 0.0.1 archive
0.1.0-alpha.12 Apr 30, 2018 Go to the documentation of front_end 0.1.0-alpha.12 Download front_end 0.1.0-alpha.12 archive
0.1.0-alpha.11 Mar 22, 2018 Go to the documentation of front_end 0.1.0-alpha.11 Download front_end 0.1.0-alpha.11 archive
0.1.0-alpha.10 Feb 14, 2018 Go to the documentation of front_end 0.1.0-alpha.10 Download front_end 0.1.0-alpha.10 archive
0.1.0-alpha.9 Feb 9, 2018 Go to the documentation of front_end 0.1.0-alpha.9 Download front_end 0.1.0-alpha.9 archive

All 19 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: Flutter, web, other

No libraries.

Issues and suggestions

Fix lib/src/fasta/testing/kernel_chain.dart.

Analysis of lib/src/fasta/testing/kernel_chain.dart failed with 15 errors, including:

line 33 col 8: Target of URI doesn't exist: 'package:testing/testing.dart'.

line 63 col 12: The method 'pass' isn't defined for the class 'Print'.

line 81 col 16: The method 'pass' isn't defined for the class 'Verify'.

line 102 col 14: The method 'pass' isn't defined for the class 'TypeCheck'.

line 155 col 18: The method 'fail' isn't defined for the class 'MatchExpectation'.

Fix lib/src/fasta/testing/scanner_chain.dart.

Analysis of lib/src/fasta/testing/scanner_chain.dart failed with 17 errors, including:

line 7 col 8: Target of URI doesn't exist: 'package:testing/testing.dart'.

line 13 col 20: Classes can only extend other classes.

line 13 col 20: Undefined class 'Step'.

line 13 col 25: The name 'TestDescription' isn't a type so it can't be used as a type argument.

line 13 col 53: The name 'ChainContext' isn't a type so it can't be used as a type argument.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use front_end.dart.

Fix additional 13 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/byte_store/protected_file_byte_store.dart (4 hints)
  • lib/src/base/errors.dart (2 hints)
  • lib/src/codegen/tools.dart (2 hints)
  • lib/src/base/jenkins_smi_hash.dart (1 hint)
  • lib/src/base/uri_kind.dart (1 hint)
  • lib/src/fasta/colors.dart (1 hint)
  • lib/src/fasta/crash.dart (1 hint)
  • lib/src/fasta/deprecated_problems.dart (1 hint)
  • lib/src/fasta/kernel/body_builder.dart (1 hint)
  • lib/src/fasta/scanner/error_token.dart (Run dartfmt to format lib/src/fasta/scanner/error_token.dart.)
  • lib/src/fasta/scanner/scanner_main.dart (Run dartfmt to format lib/src/fasta/scanner/scanner_main.dart.)
  • lib/src/fasta/type_inference/type_schema.dart (1 hint)
  • lib/src/fasta/type_inference/type_schema_environment.dart (Run dartfmt to format lib/src/fasta/type_inference/type_schema_environment.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48.0 <3.0.0
charcode ^1.1.1 1.1.2
convert ^2.0.1 2.0.2
crypto ^2.0.2 2.0.6
kernel 0.3.4 0.3.4
meta ^1.1.1 1.1.6
package_config ^1.0.1 1.0.5
path ^1.3.9 1.6.2
source_span ^1.2.3 1.4.1
yaml ^2.1.12 2.1.15
Transitive dependencies
collection 1.14.11
logging 0.11.3+2
string_scanner 1.0.3
typed_data 1.1.6
Dev dependencies
analyzer >=0.31.0 <0.33.0
args >=0.13.0 <2.0.0 1.5.0
build_integration
dart_style ^1.0.7
json_rpc_2 ^2.0.4
mockito ^2.0.2
stream_channel ^1.6.1
test ^0.12.0
test_reflective_loader ^0.1.0
web_socket_channel ^1.0.4