This package provides a low-level API for use by compiler back ends that wish to implement the Dart language. It is intended for eventual use by dev_compiler, dart2js, and the Dart VM. In addition, it will share implementation details with the analyzer package--this will be accomplished by having the analyzer package import (and re-export) parts of this package's private implementation.
End-users should use the [dartanalyzer][analyzercli] command-line tool to analyze their Dart code.
Integrators that want to write tools that analyze Dart code should use the [analyzer] package.
Note: The APIs in this package are in an early state; developers should be careful about depending on this package.
Add this to your package's pubspec.yaml file:
dependencies: front_end: ^0.1.0-alpha.4
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:front_end/compilation_error.dart'; import 'package:front_end/compiler_options.dart'; import 'package:front_end/dependency_grapher.dart'; import 'package:front_end/file_system.dart'; import 'package:front_end/incremental_kernel_generator.dart'; import 'package:front_end/incremental_resolved_ast_generator.dart'; import 'package:front_end/kernel_generator.dart'; import 'package:front_end/memory_file_system.dart'; import 'package:front_end/physical_file_system.dart'; import 'package:front_end/resolved_ast_generator.dart'; import 'package:front_end/summary_generator.dart';
|0.1.9||Jan 16, 2019|
|0.1.8||Dec 19, 2018|
|0.1.7||Nov 29, 2018|
|0.1.6+9||Dec 11, 2018|
|0.1.6+8||Nov 29, 2018|
|0.1.6+7||Nov 28, 2018|
|0.1.6+6||Nov 21, 2018|
|0.1.6+5||Nov 14, 2018|
|0.1.6+4||Nov 14, 2018|
|0.1.6+3||Nov 6, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.12.0 <2.0.0|