front_end 0.1.0-alpha.4.1

  • README.md
  • Installing
  • Versions
  • 48

Front end for Dart

This package provides a low-level API for use by compiler back ends that wish to implement the Dart language. It is intended for eventual use by dev_compiler, dart2js, and the Dart VM. In addition, it will share implementation details with the analyzer package--this will be accomplished by having the analyzer package import (and re-export) parts of this package's private implementation.

End-users should use the [dartanalyzer][analyzercli] command-line tool to analyze their Dart code.

Integrators that want to write tools that analyze Dart code should use the [analyzer] package.

Note: The APIs in this package are in an early state; developers should be careful about depending on this package.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  front_end: ^0.1.0-alpha.4.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:front_end/compilation_error.dart';
import 'package:front_end/compiler_options.dart';
import 'package:front_end/dependency_grapher.dart';
import 'package:front_end/file_system.dart';
import 'package:front_end/incremental_kernel_generator.dart';
import 'package:front_end/incremental_resolved_ast_generator.dart';
import 'package:front_end/kernel_generator.dart';
import 'package:front_end/memory_file_system.dart';
import 'package:front_end/physical_file_system.dart';
import 'package:front_end/resolved_ast_generator.dart';
import 'package:front_end/summary_generator.dart';
  
Version Uploaded Documentation Archive
0.1.6 Oct 4, 2018 Go to the documentation of front_end 0.1.6 Download front_end 0.1.6 archive
0.1.5 Sep 12, 2018 Go to the documentation of front_end 0.1.5 Download front_end 0.1.5 archive
0.1.4+2 Oct 4, 2018 Go to the documentation of front_end 0.1.4+2 Download front_end 0.1.4+2 archive
0.1.4+1 Aug 31, 2018 Go to the documentation of front_end 0.1.4+1 Download front_end 0.1.4+1 archive
0.1.4 Jul 20, 2018 Go to the documentation of front_end 0.1.4 Download front_end 0.1.4 archive
0.1.3 Jul 4, 2018 Go to the documentation of front_end 0.1.3 Download front_end 0.1.3 archive
0.1.2 Jun 26, 2018 Go to the documentation of front_end 0.1.2 Download front_end 0.1.2 archive
0.1.1 May 30, 2018 Go to the documentation of front_end 0.1.1 Download front_end 0.1.1 archive
0.1.0 May 14, 2018 Go to the documentation of front_end 0.1.0 Download front_end 0.1.0 archive
0.0.1 Oct 17, 2016 Go to the documentation of front_end 0.0.1 Download front_end 0.0.1 archive

All 23 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
96
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0