front_end 0.1.0-alpha.5

  • README.md
  • Installing
  • Versions
  • 48

Front end for Dart

This package provides a low-level API for use by compiler back ends that wish to implement the Dart language. It is intended for eventual use by dev_compiler, dart2js, and the Dart VM. In addition, it will share implementation details with the analyzer package--this will be accomplished by having the analyzer package import (and re-export) parts of this package's private implementation.

End-users should use the [dartanalyzer][analyzercli] command-line tool to analyze their Dart code.

Integrators that want to write tools that analyze Dart code should use the [analyzer] package.

Note: The APIs in this package are in an early state; developers should be careful about depending on this package.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  front_end: ^0.1.0-alpha.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:front_end/front_end.dart';
  
Version Uploaded Documentation Archive
0.1.7 Nov 29, 2018 Go to the documentation of front_end 0.1.7 Download front_end 0.1.7 archive
0.1.6+9 Dec 11, 2018 Go to the documentation of front_end 0.1.6+9 Download front_end 0.1.6+9 archive
0.1.6+8 Nov 29, 2018 Go to the documentation of front_end 0.1.6+8 Download front_end 0.1.6+8 archive
0.1.6+7 Nov 28, 2018 Go to the documentation of front_end 0.1.6+7 Download front_end 0.1.6+7 archive
0.1.6+6 Nov 21, 2018 Go to the documentation of front_end 0.1.6+6 Download front_end 0.1.6+6 archive
0.1.6+5 Nov 14, 2018 Go to the documentation of front_end 0.1.6+5 Download front_end 0.1.6+5 archive
0.1.6+4 Nov 14, 2018 Go to the documentation of front_end 0.1.6+4 Download front_end 0.1.6+4 archive
0.1.6+3 Nov 6, 2018 Go to the documentation of front_end 0.1.6+3 Download front_end 0.1.6+3 archive
0.1.6+2 Nov 2, 2018 Go to the documentation of front_end 0.1.6+2 Download front_end 0.1.6+2 archive
0.1.6+1 Oct 25, 2018 Go to the documentation of front_end 0.1.6+1 Download front_end 0.1.6+1 archive

All 33 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
96
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0-dev.infinity