This package provides a low-level API for use by compiler back ends that wish to implement the Dart language. It is intended for eventual use by dev_compiler, dart2js, and the Dart VM. In addition, it will share implementation details with the analyzer package--this will be accomplished by having the analyzer package import (and re-export) parts of this package's private implementation.
End-users should use the [dartanalyzer][analyzercli] command-line tool to analyze their Dart code.
Integrators that want to write tools that analyze Dart code should use the [analyzer] package.
Note: The APIs in this package are in an early state; developers should be careful about depending on this package.
Add this to your package's pubspec.yaml file:
dependencies: front_end: ^0.1.0-alpha.6
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.4||Jul 20, 2018|
|0.1.3||Jul 4, 2018|
|0.1.2||Jun 26, 2018|
|0.1.1||May 30, 2018|
|0.1.0||May 14, 2018|
|0.0.1||Oct 17, 2016|
|0.1.0-alpha.12||Apr 30, 2018|
|0.1.0-alpha.11||Mar 22, 2018|
|0.1.0-alpha.10||Feb 14, 2018|
|0.1.0-alpha.9||Feb 9, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.12.0 <2.0.0-dev.infinity|