fullscreen_mode 1.0.1

  • README.md
  • Example
  • Installing
  • Versions
  • 31

Deprecated: this plugin is no longer maintained. #

Instead of using this plugin, use services/SystemChrome#setEnabledSystemUIOverlays, which is provided by native flutter services.

Enter fullscreen mode: SystemChrome.setEnabledSystemUIOverlays([])

Exit fullscreen mode: SystemChrome.setEnabledSystemUIOverlays(SystemUiOverlay.values)


fullscreen_mode #

Enter and exit fullscreen mode in Flutter apps.

Currently Android-only.

Getting Started #

Enter fullscreen mode: FullscreenMode.setFullscreen()

Exit fullscreen mode: FullscreenMode.setNormal()

demo!

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter/material.dart';
import 'package:flutter/services.dart';

import 'package:fullscreen_mode/fullscreen_mode.dart';

void main() {
  runApp(new MaterialApp(
      home: new Scaffold(
          appBar: new AppBar(title: new Text("Fullscreen Demo")),
          body: new Center(child: new Column(children: <Widget>[
            new RaisedButton(
                child: new Text("normal"), onPressed: FullscreenMode.setNormal),
            new RaisedButton(
                child: new Text("fullscreen"),
                onPressed: FullscreenMode.setFullscreen),
          ])))));
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fullscreen_mode: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fullscreen_mode/fullscreen_mode.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jul 9, 2017 Go to the documentation of fullscreen_mode 1.0.1 Download fullscreen_mode 1.0.1 archive
1.0.0 May 17, 2017 Go to the documentation of fullscreen_mode 1.0.0 Download fullscreen_mode 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
31
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.