func2 2.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new54

func2 Pub

Repository for the func package containing convenience typedefs defining commonly used function types to make it simpler to define members that return specific function types.

This is a fork of the original func package by the Dart team upgraded to Dart SDK 2.0

Changelog

2.0.1

  • make pub analyzer happy

2.0.0

  • upgrade to Dart SDK 2.0

example/example.dart

import 'package:func2/func.dart';

void main() {
  Func2 add = (a, b) => a + b;

  print(add(1, 2));
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  func2: ^2.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:func2/func.dart';
  
Version Uploaded Documentation Archive
2.0.1 Nov 21, 2018 Go to the documentation of func2 2.0.1 Download func2 2.0.1 archive
2.0.0 Nov 21, 2018 Go to the documentation of func2 2.0.0 Download func2 2.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Health issues and suggestions

Document public APIs (-9.77 points)

42 out of 43 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0