functional_widget_annotation 0.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new64

Build Status pub package

A package containing the necessary annotations for functional_widget code gneerator to work

0.0.1

Initial release

example/functional_widget_annotation.dart

import 'package:functional_widget_annotation/functional_widget_annotation.dart';
import 'package:flutter/widgets.dart';

@widget
Widget foo() {
  return Text("Hello World");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  functional_widget_annotation: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:functional_widget_annotation/functional_widget_annotation.dart';
  
Version Uploaded Documentation Archive
0.1.0 Dec 3, 2018 Go to the documentation of functional_widget_annotation 0.1.0 Download functional_widget_annotation 0.1.0 archive
0.0.3 Dec 3, 2018 Go to the documentation of functional_widget_annotation 0.0.3 Download functional_widget_annotation 0.0.3 archive
0.0.2 Dec 3, 2018 Go to the documentation of functional_widget_annotation 0.0.2 Download functional_widget_annotation 0.0.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:functional_widget_annotation/functional_widget_annotation.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0