Add this to your package's pubspec.yaml file:
dependencies: functional_widget_generator: ^0.0.1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:functional_widget_generator/function_to_widget_class.dart'; import 'package:functional_widget_generator/builder.dart';
|0.0.1||Dec 2, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Dec 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: other
Platform components identified in package:
Document public APIs (-9.50 points)
19 out of 20 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.
README.md. (-30 points)
Readme should inform others about your project, what it does, and how they can use it.
CHANGELOG.md. (-20 points)
Changelog entries help clients to follow the progress in your code.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
Package is pre-v0.1 release. (-10 points)
While there is nothing inherently wrong with versions of
0.0.*, it usually means that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.0.0-dev.68.0 <3.0.0|